Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,641 Members 44,280 Now Online
XDA Developers Android and Mobile Development Forum

bam_dmux_wakelock Woes

Tip us?
 
gyrocks
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Aug 2009
Default bam_dmux_wakelock Woes

Hi everyone. So I've scoured the web high and low for some help on this topic, and so far I've gotten some scattered information, but not a lot of concrete solutions.

I'm having bad idle battery drain problems on my un-rooted, stock Verizon N9000V (MJE). Using BetterBatteryStats I've singled out bam_dmux_wakelock as the culprit. From what I've been able to find online, I guess this is a kernel level wakelock caused by something accessing cellular (not-wifi) data when the phone is asleep. I've pulled my hair out individually un-installing apps one at a time to see if I can pinpoint the culprit. I've also factory reset the phone and started from scratch, adding my apps one at a time, but due to the intermittent nature of this wakelock (it is not always present) I've had a whole bunch of false positives, thinking I'm safe only to have it pop up again the next day.

At it's worst, this wakelock is keeping my phone out of deep sleep around 50-75% of total battery time.

I do know that a thread exists on this topic over on the GSIII board, and I'm not trying to duplicate threads. I'm really just wondering whether any Note 3 users have experienced this patricular wakelock, and maybe what you've done to combat it on this particular phone. I've already tried some of the things others have suggested from other phones (disable Google+, disable Hangouts etc.) I'm really at my wit's end.

Thanks for your time and I appreciate any input.
 
xdm9mm
Old
#2  
xdm9mm's Avatar
Senior Member
Thanks Meter 54
Posts: 251
Join Date: Dec 2013
This is also what is causing my rooted Note 3 to not go to deep sleep.

From previous xda threads, it looks like it is also present on the S3, maybe other phones too.

example:
http://forum.xda-developers.com/show....php?t=1811365

Maybe the solution is to just turn off Mobile Data when you are not using internet.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes