Post Reply

[Q] Phone not receiving/sending calls/sms

OP Pkmns

20th April 2014, 09:55 AM   |  #1  
OP Member
Thanks Meter: 7
 
44 posts
Join Date:Joined: Feb 2013
Hello,

I have an SIII Mini. Everything is stock, except for the fact that it is rooted.
At times, when somebody calls, the phone won't ring and the caller will immediately hear the answering service message (as though the phone was off). When this happens, there is no way to call anybody as well and the only way to fix it seems to be removing the battery and turning on again. Does anybody know how to fix this? Could flashing the stock ROM again do any good?

Also, the data network connection seems to be embarassingly slow. Does it have anything to do with this?
20th April 2014, 10:28 AM   |  #2  
xXPR0T0TYPEXx's Avatar
Senior Member
Thanks Meter: 198
 
555 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by Pkmns

Hello,

I have an SIII Mini. Everything is stock, except for the fact that it is rooted.
At times, when somebody calls, the phone won't ring and the caller will immediately hear the answering service message (as though the phone was off). When this happens, there is no way to call anybody as well and the only way to fix it seems to be removing the battery and turning on again. Does anybody know how to fix this? Could flashing the stock ROM again do any good?

Also, the data network connection seems to be embarassingly slow. Does it have anything to do with this?

Do you get the same problem if you use a other sim card? Or try to remove sim and put it back. Maybe this solve your problem
20th April 2014, 08:17 PM   |  #3  
OP Member
Thanks Meter: 7
 
44 posts
Join Date:Joined: Feb 2013
Quote:
Originally Posted by xXPR0T0TYPEXx

Do you get the same problem if you use a other sim card? Or try to remove sim and put it back. Maybe this solve your problem

I haven't tried other SIMs, but I tried mine on another phone and everything seemed to work. I forgot to mention that each time I remove the battery and put it back I do the same with the SIM, so I actually don't know which of the two is the actual cause - I'll check as soon as this happens again.
20th April 2014, 09:28 PM   |  #4  
Senior Member
Flag Romania
Thanks Meter: 73
 
234 posts
Join Date:Joined: Oct 2012
Donate to Me
More
Check it and tell us what was doing the trick.. maybe you need a new battery , also check if the battery is a bit bigger in the middle than it was when you bought the phone

Trimis de pe al meu GT-I8190 folosind Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes