Lollipop Leak Available for the Sprint Galaxy S5

Since the Android 5.0Lollipop’s official release not too long ago, we’ve seen … more

CPU Spy Gets an Android Lollipop Makeover

At some point in the distant past, you probably heard of CPU Spy for Android by XDARetired … more

Amazon Fire TV Stick vs Chromecast – XDA TV

There is no doubt that Amazon is a huge player in many markets, and they want to be a huge … more

Fight the Heat and Conserve Battery with EaseUS Coolphone

Memory hungry Android applications are often responsible for making our device … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Galaxy Note 2 sensors not working!

OP epix1718

10th January 2014, 01:41 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Oct 2011
I've had this issue for quite a while now.. at first I figured it was just a bug as my screen would no longer rotate but I've flashed and tried several different roms (Probam jelly bean, KitKat, and now on Temasek V28 KitKat) and have tried a few different Kernels such as Devil 2.3.2 and currently using the stock Temasek kernel.

I've downloaded some sensor apps and they list my sensors, but whenever I go to test them such as the accelerom3534, gyroscope, compass.. they don't work at all.. They just say "waiting for data"

The Proximity sensor still appears to be working though.

Anyone had this issue? My phone I don't think is damaged.. I've dropped it on some small falls in the past but it's been in a nice cover as well.
10th January 2014, 03:49 AM   |  #2  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Oct 2011
Small update:

Went back to a rooted stock 4.1.2 AT&T ROM, stock kernel, stock modem.. no change. Must be the hardware being broken
10th January 2014, 04:00 AM   |  #3  
ShrekOpher's Avatar
Senior Member
Flag St. Louis
Thanks Meter: 257
 
440 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by epix1718

Small update:

Went back to a rooted stock 4.1.2 AT&T ROM, stock kernel, stock modem.. no change. Must be the hardware being broken

Is it your home screen that doesn't rotate or will no apps work.

Sent from my SAMSUNG-SGH-I317 using xda app-developers app
10th January 2014, 04:56 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Oct 2011
Quote:
Originally Posted by ShrekOpher

Is it your home screen that doesn't rotate or will no apps work.

Sent from my SAMSUNG-SGH-I317 using xda app-developers app

None of the apps will rotate, or say a picture in "gallery". Home screen I know was never designed to rotate.

Also just tried the 1-Click ODIN restore to unrooted stock rom, no difference Screen still does not rotate in any apps.
10th January 2014, 05:48 AM   |  #5  
gregsarg's Avatar
Senior Member
Flag B.F.E.
Thanks Meter: 3,719
 
4,388 posts
Join Date:Joined: Apr 2011
More
Sounding like a hardware issue...
Sorry to hear that ...g
Last edited by gregsarg; 10th January 2014 at 05:52 AM.
11th January 2014, 07:54 PM   |  #6  
ShrekOpher's Avatar
Senior Member
Flag St. Louis
Thanks Meter: 257
 
440 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by epix1718

None of the apps will rotate, or say a picture in "gallery". Home screen I know was never designed to rotate.

Also just tried the 1-Click ODIN restore to unrooted stock rom, no difference Screen still does not rotate in any apps.

the only other option I can suggest is to check and make sure all of your settings that effect screen rotation of cleared. Make sure you don't have smart stay on and you have screen rotation enabled in your settings. You may also want to turn them on if they are off and reboot your phone. Then turn them back off and reboot your phone again. If that doesn't fix it I would assume its a hardware issue.

Did you drop your phone recently or get it wet or damp. That's the only thing I have heard can cause the hardware issue.
21st April 2014, 09:21 PM   |  #7  
Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Sep 2009
bringing this thread back to life sense I couldn't do the same for my sensors
Hello there! So I have had a similar experience with the Note 2. It is not hardware related as far as I can determine because I swapped out the prox sensor on mine and it did not help. I feel that it is kernel related. On my previous Note 2, I flashed some kernel, prox sensor stopped working. I flashed back to stock AT&T and it worked for one call before quitting again. That's when I tried a new sensor and camera unit. The phone was under warranty so I triangled away and traded it. With the current Note 2, I flashed Sky note 9.3 and then after a while the prox sensor stopped working, I just thought okay with whatever maybe it's the kernel I'm using. I wanted to upgrade to Sky note Air, so I did. Got all settled in and decided to see if their provided kernel fixed my call sensor, no cigar. So I went into *#0*# and realized that none of my sensors were working. Tried using Devil Kernel, stock, stock ROM, all sorts of configurations and I can't revive any of them. Feeling very defeated.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes