Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,846 Members 37,196 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Super User disappeared / Clock Work instruction

Tip us?
 
Guilherme1
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Default [Q] Super User disappeared / Clock Work instruction

Hello and good evening everyone.

I'm a noob at android stuff, so I decided to ask you guys for help before anything dumb.


I have an Samsung GT-I9192. I rooted it about a week ago using Kingo (v.1.2.2) and it went ok (and voided Knox).
But today, after I turned it, an OS update dialog showed up. I went to use Titanium Backup and it said it didn't have root privileges. I checked and the Super User app disappeared.

I searched here at the forum and someone suggested downloading a new super user app. Did that and root access was not allowed. I've used the root checker and it confirmed that the device was unrooted.

I've tried rooting the device again via Kingo. It flashes the device and shows a message saying that the rooting was successful. However, when I try to use super user access it still is denied.

So what could fix the issue?

I was already thinking at installing ClockWork Mod to do nandroid backups, so if it is possible to do the two things at one time it would be very helpful.


I'm afraid of hard bricking it by flashing something wrong. So, these are the information I found:
Android Version: 4.2.2
Firmware: I9192UBUBMK4
Kernel: 3.4.0-2125686 / se.infra@R0303-1 3#1
(Compilation/Build?): JDQ39.I9192UBUBMK4
SELinux: Enforcing.
This is a Brazil/South America phone model.

Also, I'm thinking at installing Clock Work Mod to do nandroid backups and avoid soft bricks. Is this the safer way?


Thanks in advance, people!
 
Guilherme1
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Default Fixed super user

Hello everyone, I fixed it by myself.


I did a search on /system/app and found the SuperSU.apk pack that I had before the OS changed.
I choose to install and it asked to update the app instead.

Installation proceeded and then the SuperSU app returned, with all the settings I had, just like it was before. Even the logs were unchanged.


Anyway, I still would like some information about clockwork mod. Can anyone point me the directions?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes