Question [Q] Googy-Max2 Kernel 2.2.2_CWM

is that compatible if I flash Googy-Max2 Kernel 2.2.2_CWM on i9300(with based slimkat 4.4.2)? Any help? thanks.