Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,924 Members 45,501 Now Online
XDA Developers Android and Mobile Development Forum

Hardware Debugging Using Eclipse

Tip us?
 
parthnatu
Old
#1  
parthnatu's Avatar
Junior Member - OP
Thanks Meter 1
Posts: 22
Join Date: Nov 2013
Location: Mumbai
Exclamation Hardware Debugging Using Eclipse

I started using ADT to develop new Android applications recently. After a number if tests,I found the emulator to be painfully slow for me. So I decided to use my Razr i to debug it directly. The device is recognized and shows up int the debug list. But when I try to run it, it cannot install the .apk file for my application and says "INVALID APK FILE". I've tried this with various other applications too and it still doesn't work (so I think I can eliminate the possibility of something being wrong with my app itself). Also, I am using Anerik's JellyAOSP ROM. Anybody for a fix?

Thanks.
 
5m00v3
Old
(Last edited by 5m00v3; 23rd April 2014 at 09:27 AM.)
#2  
Member
Thanks Meter 28
Posts: 79
Join Date: Nov 2013
Location: Hamburg
Hi, did you use the x86 Android libs? because Ri is x86 hardware... (just my silly idea)
Or didnīt export signed APK? U can make ur own key by File->AndroidTools->Export Signed APK...
Did you allowed "install unsigned Apps" in your Ri Settings?
Maybe some "Manifest" Settings / Permissions? Install Directory: Auto?

I donīt use my Ri to develop, so i never face this problem.
Also be sure to not use 64bit Java or 64bit ADT !!!
I can also test your APK on my Stock RI if u want...

greetz
Phones: HTC Explorer (Pico) - CyanogenMod / Razr i - Root with locked BL Daily / Huawei G510-0100 - as developer device
[HARDWARE MOD] Microphone Cover - RAZRi - - - - - [APP] Playstation Mobile - ROOT needed
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes