Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,052 Members 45,530 Now Online
XDA Developers Android and Mobile Development Forum

Mediaserver?

Tip us?
 
CrimsonCrap
Old
#1  
Member - OP
Thanks Meter 4
Posts: 43
Join Date: Apr 2014
Default Mediaserver?

So I have a bit of an issue with the mediaserver battery drain.I am on rooted stock (12.0.A.2.254) with sdcard swappped as primary using a script.The phone works fine with quite impressive battery life but I have noticed that whenever i play games my mediaserver battery drain increases massively.After I am done playing, the mediaserver also stops.I came from using a Huawei phone (on which I also had the sdcard as primary) and I used to play alot of high end games on it but mediaserver battery drain was never an issue.It never used to go past 6 percent.But with the Xperia SP, the mediaserver has more battery drain than the screen itself.I have uninstalled some bloatware but i highly doubt that's what might be causing it as the mediaserver only spikes while playing games.
Could the sdcard being set as primary have something to do with this?
any help would be appreciated.

Thanks
 
Nanostray
Old
#2  
Nanostray's Avatar
Senior Member
Thanks Meter 102
Posts: 632
Join Date: Oct 2012
Quote:
Originally Posted by CrimsonCrap View Post
So I have a bit of an issue with the mediaserver battery drain.I am on rooted stock (12.0.A.2.254) with sdcard swappped as primary using a script.The phone works fine with quite impressive battery life but I have noticed that whenever i play games my mediaserver battery drain increases massively.After I am done playing, the mediaserver also stops.I came from using a Huawei phone (on which I also had the sdcard as primary) and I used to play alot of high end games on it but mediaserver battery drain was never an issue.It never used to go past 6 percent.But with the Xperia SP, the mediaserver has more battery drain than the screen itself.I have uninstalled some bloatware but i highly doubt that's what might be causing it as the mediaserver only spikes while playing games.
Could the sdcard being set as primary have something to do with this?
any help would be appreciated.

Thanks
Search your SDcard and SDcard1 for 0kb and/or corrupted files/empty folders. Delete those
Devices:
Xperia Ray (587)
Electric Circuit Fried
UHD-ROM
Locked Bootloader
CWM-Recovery (Xparts)


Xperia SP (205)
Existenz Ultra 4.0.0
Locked Bootloader
3-way recoveries


Hit Thanks if I helped you
 
CrimsonCrap
Old
#3  
Member - OP
Thanks Meter 4
Posts: 43
Join Date: Apr 2014
Default nope :/

Quote:
Originally Posted by Nanostray View Post
Search your SDcard and SDcard1 for 0kb and/or corrupted files/empty folders. Delete those
Freshly formatted both sdcard0 and sdcard1 but the problem still persists :/.
 
MasterYopta
Old
#4  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Sep 2013
Quote:
Originally Posted by CrimsonCrap View Post
Freshly formatted both sdcard0 and sdcard1 but the problem still persists :/.
I am use this init.d script
Code:
#!/system/bin/sh

sleep 60
echo "-17" > /proc/`pidof mediaserver`/oom_adj
renice -18 `pidof mediaserver`
For my phone it's helpfull
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes