Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,772,461 Members 47,512 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Lost access to internal storage

Tip us?
 
lopelisoli
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Default [Q] Lost access to internal storage

Hello,

In the process of rooting and trying to install CWM Recovery in preparation to flash Cyanogenmod, I seem to have denied myself access to the phone's internal storage. In the "File Manager" app, I get the following screen:

Local: /storage
No files
No search results

In addition, any app that requires access to internal memory will not work, instead showing messages such as "Try again after scanning media files" or "Not enough storage". If I plug in the USB cable and set it to "Media sync (MTP)" mode, Windows Explorer will show the device but list the internal storage as having "0 bytes" and no files.

I already tried the following:

- Factory reset
- Flashing the official ROM through the Windows Enabler / UpTestEX tools

In both tries the phone was "reset", as in it returned to the initial Android welcome screen where you set up your Google account, but in each case I still didn't have access to internal storage.

This is what I have in the "About phone -> Software information" option:

Android version: 4.1.2
Baseband version: APQ8064T/MDM9x15M
Kernel version: 3.4.0
Build number: JZO54K
Software version: E98810b

The phone does not have Wi-Fi access either, which is why I was tinkering around with custom ROMs in the first place, so I won't be able to download anything to it as part of the solution.

Is there anything else I can try?
 
ackliph
Old
#2  
Senior Member
Thanks Meter 104
Posts: 379
Join Date: Jan 2010
Location: Little Rock
I'm guessing you used FreeGee to install CWM? Perhaps try restoring?

If that didn't work... Id move the EFS backups to my computer. I'd make a NAND backup in CWM. Then I'd get CM and gapps on a micro SD. I'd do a format of system, data, and cache. Then I'd install CM and gapps. Then I'd cross my fingers.

Sent from my LG-E980 using Tapatalk
HTC Inspire 4G *sold*
Samsung Galaxy Exhibit - SlimBean *wow*
HTC ONE XL *sold*
Samsung Galaxy Nexus *sold*
LG Nexus 4 *sent back*
Samsung Galaxy S II SGH-T989 Hercules
LG Optimus G Pro LG-E980
AT&T GoPhone 2GB Unlimited
 
lopelisoli
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
ackliph,

Since I didn't have Wi-Fi access on the phone, and at the time I didn't know how to reverse tether it to the computer, I was looking for a procedure to install CWM Recovery that didn't involve downloading files directly within the phone (only transfering via USB). Right now I can't find the exact instructions I used, but it was similar to what is described by hkfriends in this thread: http://forum.xda-developers.com/show....php?t=2361941, the only difference being that the image I downloaded was not that one.

I rooted the phone with Universal Root, then followed those instructions to install CWM Recovery. It seemed to have worked, but when I rebooted... nothing happened! The phone booted normally, and if I tried entering recovery mode all I got was the stock LG recovery.

I continued looking for another way to install a custom recovery, but instead came upon instructions to flash KDZ files with UpTestEx. Since the immediate problem I was trying to solve was the lack of Wi-Fi access (and not really the custom ROM), I thought it couldn't hurt to try updating the stock ROM. The procedure did update my ROM, but I ended up in my current predicament: no access to internal storage, and still no Wi-Fi access! It even managed to unroot the phone.

So your suggestion would be to try installing CM via a microSD card. OK, I can get a microSD and try that. However, I do believe I will need root access to do anything of the sort. I tried Universal Root again, and got the following messages:

Quote:
Beginning Root Process
/system/bin/sh: can't create /sdcard/G_security: Permission denied

Now change from Charge Only to MTP
No need to disconnect USB
Press Enter after making the change.

adbd cannot run as root in production builds
error: device not found
If uid=0(root), gid=0(root) is displayed
Press Enter to Continue

1955 KB/s (1085140 bytes in 0.542s)
mount: permission denied (are you root?)
cp: can't create '/system/xbin/busybox': Read-only file system
failed to copy 'su' to '/system/xbin/su': Read-only file system
failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file system
Unable to chown /system/xbin/su: No such file or directory
You are now properly Rooted.

Evidently, that didn't work.

I guess I will need some other method of rooting it.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes