Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,714 Members 46,002 Now Online
XDA Developers Android and Mobile Development Forum

Weird charge current

Tip us?
 
sackynuts
Old
(Last edited by sackynuts; 19th April 2014 at 02:11 PM.)
#1  
sackynuts's Avatar
Senior Member - OP
Thanks Meter 15
Posts: 328
Join Date: Apr 2010
Location: Copenhagen
Default Weird charge current

Hello guys,

I have a annoying problem with my beloved 9505. The charge current changes each time i plug the charger in and out. I've tried with the stock cable and with my n10 cable. I have to plug it in and out until it hits 1200 mah (the highest I can get) - i were able to hit 1900 some time ago (after switching from the n10 cable to the stock), but then i began to act up, like the n10 cable did.. and now it's really annoying! Is it a defect charger port? Maybe it needs a cleaning? I wasn't able to find any info on others with this issue.
Samsung Galaxy S II i9100 16 GB

Features: Overheating, battery drain and yellow tint <3
 
qtwrk
Old
#2  
qtwrk's Avatar
Senior Member
Thanks Meter 810
Posts: 2,496
Join Date: Sep 2011
Location: Barcelona
Did you flash any kernel? And by the way, as far as I know, it only up to 1200 when screen is on, and 1900 when screen is off
if my words are useful or helpful to you , i will appreciate it you click thanks button
GT-i9023 Nexus S
GT-i9250 Galaxy Nexus
GT-i9300 Galaxy S III
GT-s5830 Galaxy Ace
GT-i9300 Galaxy S III
GT-i9506 Galaxy S IV 4G+
GT-i9505 Galaxy S IV (current)
 
Breach1337
Old
#3  
Junior Member
Thanks Meter 2
Posts: 28
Join Date: Jul 2013
Location: Brussels
Quote:
Originally Posted by sackynuts View Post
Hello guys,

I have a annoying problem with my beloved 9505. The charge current changes each time i plug the charger in and out. I've tried with the stock cable and with my n10 cable. I have to plug it in and out until it hits 1200 mah (the highest I can get) - i were able to hit 1900 some time ago (after switching from the n10 cable to the stock), but then i began to act up, like the n10 cable did.. and now it's really annoying! Is it a defect charger port? Maybe it needs a cleaning? I wasn't able to find any info on others with this issue.
On the OEM charger you should be seeing 1200mA with the screen on and 1900mA when the phone has just come out out of sleep.

My S4 has so far burnt through 3 USB cables (yes, there's such a thing). If you're seeing weird values such as 760 mA etc try with another cable.
 
qtwrk
Old
#4  
qtwrk's Avatar
Senior Member
Thanks Meter 810
Posts: 2,496
Join Date: Sep 2011
Location: Barcelona
Actually it's kinda weird, you see, I have 2 Samsung cables, one from my older s3 and one from the current s4.

If I plug s3 cable into s4 charger, it never reaches such high current...

Perhaps some trick on the cable?
if my words are useful or helpful to you , i will appreciate it you click thanks button
GT-i9023 Nexus S
GT-i9250 Galaxy Nexus
GT-i9300 Galaxy S III
GT-s5830 Galaxy Ace
GT-i9300 Galaxy S III
GT-i9506 Galaxy S IV 4G+
GT-i9505 Galaxy S IV (current)
 
Breach1337
Old
#5  
Junior Member
Thanks Meter 2
Posts: 28
Join Date: Jul 2013
Location: Brussels
Yes, the cable is fried. 2A proves too much for many USB cable even if it works at the beginning.
 
sackynuts
Old
#6  
sackynuts's Avatar
Senior Member - OP
Thanks Meter 15
Posts: 328
Join Date: Apr 2010
Location: Copenhagen
Hello again guys,

I am using the "[ROM]KOT49H【4.4.2】Google Play Edition" ROM which uses Ktoonsez kernel. The kernel has various charge-settings (including fast charge). None of them affects my charging current. I already tried a new cable - the original.. My n10 cable stopped working. The cable is acting fine again, but had a weird period, which led me to start this post :P

Maybe I should try another kernel, although i wrote in the thread and asked if others had experienced issues with the current, but nobody replied, so i'm gussing that it's not a issue.

Maybe it's the charger port that needs cleaning? Could that be possible?
Samsung Galaxy S II i9100 16 GB

Features: Overheating, battery drain and yellow tint <3
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes