5,604,631 Members 41,041 Now Online
XDA Developers Android and Mobile Development Forum

Corrupt Cache Partition - help needed

Tip us?
 
nfin1te
Old
#11  
nfin1te's Avatar
Senior Member - OP
Thanks Meter 28
Posts: 243
Join Date: Dec 2010
Location: Vienna
Quote:
Originally Posted by Incep View Post
Maybe you don't have parted installed on your phone. Each command is actually it's own program, which lies in a folder which is either /bin for normal apps, and /sbin for system-changing apps. So probably check /sbin if there is a binary file called 'parted' there. But be careful of this programů It can be very destructive.
Yeah thx, i just managed to push the necessary files.
 
nfin1te
Old
(Last edited by nfin1te; 6th December 2013 at 02:01 PM.)
#12  
nfin1te's Avatar
Senior Member - OP
Thanks Meter 28
Posts: 243
Join Date: Dec 2010
Location: Vienna
Ok, now im looking at this partition table:

(parted) print
print

Model: MMC 032G96 (sd/mmc)
Disk /dev/block/mmcblk0: 31.3GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
1 16.8MB 83.9MB 67.1MB fat16 modem
2 83.9MB 84.9MB 1049kB sbl1
3 84.9MB 85.5MB 524kB dbi
4 101MB 101MB 524kB DDR
5 117MB 118MB 1049kB aboot
6 118MB 120MB 1049kB rpm
7 134MB 151MB 16.8MB boot
8 151MB 152MB 1049kB tz
9 152MB 152MB 1024B pad
10 168MB 171MB 3146kB modemst1
11 171MB 174MB 3146kB modemst2
12 174MB 174MB 1024B pad1
13 185MB 201MB 16.8MB misc
14 201MB 235MB 33.6MB ext4 persist
15 235MB 252MB 16.8MB recovery
16 252MB 255MB 3146kB fsg
17 268MB 269MB 524kB fsc
18 269MB 269MB 524kB ssd
19 269MB 269MB 1024B pad2
20 269MB 270MB 524kB encrypt
21 285MB 294MB 8389kB ext4 drm
22 294MB 302MB 8389kB ext4 sns
23 302MB 336MB 33.6MB laf
24 336MB 369MB 33.6MB fota
25 369MB 403MB 33.6MB ext4 mpt
26 403MB 403MB 524kB dbibak
27 403MB 404MB 1049kB rpmbak
28 404MB 405MB 1049kB tzbak
29 405MB 405MB 8192B rct
30 419MB 3322MB 2902MB ext4 system
31 3322MB 3959MB 638MB cache
32 3959MB 4043MB 83.9MB tombstones
33 4043MB 4060MB 16.8MB spare
34 4060MB 4110MB 50.3MB ext4 cust
35 4110MB 31.2GB 27.1GB ext4 userdata
36 31.2GB 31.3GB 62.9MB grow

(parted)


I assume, the problem is, that cache seems screwed as it doesn't show any filesystem right?
So if i make this partition ext4, it should work again?

If i check pt31/cache, it says:

(parted) check 31
check 31
Error: Could not detect file system.
(parted)

So, im assuming, im right.
 
nfin1te
Old
#13  
nfin1te's Avatar
Senior Member - OP
Thanks Meter 28
Posts: 243
Join Date: Dec 2010
Location: Vienna
lol, man this is frustrating

(parted) mkfs ext4
mkfs ext4
Warning: The existing file system will be destroyed and all data on the
partition will be lost. Do you want to continue?
parted: invalid token: ext4
Yes/No? yes
yes
Partition number? 31
31
File system type? [ext2]? ext4
ext4
No Implementation: Support for creating ext4 file systems is not implemented
yet.
(parted)
 
nfin1te
Old
(Last edited by nfin1te; 6th December 2013 at 02:47 PM.)
#14  
nfin1te's Avatar
Senior Member - OP
Thanks Meter 28
Posts: 243
Join Date: Dec 2010
Location: Vienna
It's alive again!

ext2 worked aswell, as i/we thought - the problem was the cache partition got f'ed up. Making a new FS using parted solved the problem.

THANKS bro for pointing me in the right direction.

Edit: restored backup and everythings fine again
The Following User Says Thank You to nfin1te For This Useful Post: [ Click to Expand ]
 
emrexcem
Old
#15  
emrexcem's Avatar
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Sep 2012
Location: Izmir

 
DONATE TO ME
I have the same issue , i am running on ubuntu i but i dont quite get the instrations ?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...