Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,290 Members 46,090 Now Online
XDA Developers Android and Mobile Development Forum

[Q] PLEASE Help!!!!

Tip us?
 
tennispro820
Old
(Last edited by tennispro820; 17th April 2014 at 04:43 AM.) Reason: Title edit
#1  
Member - OP
Thanks Meter 2
Posts: 42
Join Date: Mar 2014
Question [Q] PLEASE Help!!!!

I am currently running CyanogenMod 11 (M3) for t-mobile. I really need help fixing my camera. I was having problems with my camera earlier but now it is constantly force closing. Just recently the camera updated to Google camera and I was hoping the force would not occur anymore, but now it's even worse. If any ideas how to fix PLEASE tell me because I have many needs for the camera. This how the problem occurs: I try to take a picture and it will take it then it will freeze and I have to kill the app. Then I try to restart the app but I get an "Camera error: cannot connect to the camera." The problem was really bad after I flashed the ROM so I deleted that camera and flashed a "better" one. I try to use the other features of this updated Google camera but none of them work such as: lens blur, panorama or photo sphere . I would really love having these features working or even taking regular pictures without any force closes. I have to use the camera everyday so please help as soon as possible. Please anyone help me solve this problem!!!! (Current Phone: Samsung Galaxy S3 SGH-T999)

Thanks for the help in advance!! 


Sent from my SGH-T999 using XDA Premium 4 mobile app
 
DocHoliday77
Old
#2  
DocHoliday77's Avatar
Recognized Contributor
Thanks Meter 6,042
Posts: 8,685
Join Date: May 2011
Location: HuntsVegas!!!

 
DONATE TO ME
First thing I'd do is make a nandroid backup, then factory reset. If it fixes it then some data you had was causing the issue.

Next thing to try is copy the cameradata folder from a stock rom to yours. Reboot and test.

If that doesnt help i would then Odin flash stock/root66 firmware and factory reset. Then test the camera. If its still not working it may be hardware. If it works, you can be certain its software/firmware related. No sense in more troubleshooting if you determine its hardware related.

If it works on stock but not after a clean rom flash, the rom is likely the problem. Search its thread for similar issues.

Good luck!
The Following User Says Thank You to DocHoliday77 For This Useful Post: [ Click to Expand ]
 
tennispro820
Old
#3  
Member - OP
Thanks Meter 2
Posts: 42
Join Date: Mar 2014
Quote:
Originally Posted by DocHoliday77 View Post
First thing I'd do is make a nandroid backup, then factory reset. If it fixes it then some data you had was causing the issue.

Next thing to try is copy the cameradata folder from a stock rom to yours. Reboot and test.

If that doesnt help i would then Odin flash stock/root66 firmware and factory reset. Then test the camera. If its still not working it may be hardware. If it works, you can be certain its software/firmware related. No sense in more troubleshooting if you determine its hardware related.

If it works on stock but not after a clean rom flash, the rom is likely the problem. Search its thread for similar issues.

Good luck!
Thank you so much for the reply I will try this! If the factory reset does not work do you where I would able to find the camera data folder for Stock S3 Rom?
 
DocHoliday77
Old
#4  
DocHoliday77's Avatar
Recognized Contributor
Thanks Meter 6,042
Posts: 8,685
Join Date: May 2011
Location: HuntsVegas!!!

 
DONATE TO ME
Unzip any stock based rom such as StockMod and its in the system folder.
 
tennispro820
Old
#5  
Member - OP
Thanks Meter 2
Posts: 42
Join Date: Mar 2014
Question Help?!

Quote:
Originally Posted by DocHoliday77 View Post
Unzip any stock based rom such as StockMod and its in the system folder.
The reset didn't work...I', trying to fix this camera https://play.google.com/store/apps/d...d.GoogleCamera
This camera keeps freezing and then I have to end the task. After I end the task and try to go back to camera I get an "Camera error: Can't connect to camera." The lens blur and photo sphere and panorama are not working. Also, the camera is not taking the full screen when in rear facing camera but when I change to front facing the size becomes even smaller. Any idea how I can fix these problems? I am getting frustrated
 
Soe Min Thu
Old
#6  
Member
Thanks Meter 6
Posts: 69
Join Date: Nov 2013
Default me too!!

Quote:
Originally Posted by tennispro820 View Post
The reset didn't work...I', trying to fix this camera https://play.google.com/store/apps/d...d.GoogleCamera
This camera keeps freezing and then I have to end the task. After I end the task and try to go back to camera I get an "Camera error: Can't connect to camera." The lens blur and photo sphere and panorama are not working. Also, the camera is not taking the full screen when in rear facing camera but when I change to front facing the size becomes even smaller. Any idea how I can fix these problems? I am getting frustrated
Me too! Facing all that errors and don't still know how to fix them.
 
tennispro820
Old
#7  
Member - OP
Thanks Meter 2
Posts: 42
Join Date: Mar 2014
Default Solved

Quote:
Originally Posted by Soe Min Thu View Post
Me too! Facing all that errors and don't still know how to fix them.
I figured it out...it was a ROM problem. I flashed liquid smooth 4.4.2 and it worked perfectly.
 
Soe Min Thu
Old
#8  
Member
Thanks Meter 6
Posts: 69
Join Date: Nov 2013
Quote:
Originally Posted by tennispro820 View Post
I figured it out...it was a ROM problem. I flashed liquid smooth 4.4.2 and it worked perfectly.
Ok, then, that issue would be fixed if I flash the latest nightly CM 11 Rom??
 
tennispro820
Old
#9  
Member - OP
Thanks Meter 2
Posts: 42
Join Date: Mar 2014
Quote:
Originally Posted by Soe Min Thu View Post
Ok, then, that issue would be fixed if I flash the latest nightly CM 11 Rom??
It is a possibility, you can try and see. I flashed a completely different ROM.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes