Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,037 Members 52,056 Now Online
XDA Developers Android and Mobile Development Forum

Stuck on Rethink Possible screen.

Tip us?
 
nomoney4me
Old
#1  
Member - OP
Thanks Meter 7
Posts: 32
Join Date: Feb 2014
Default Stuck on Rethink Possible screen.

I flashed a few roms like PACman and SHOstock and it booted up but it seems that it was lagging quite badly and camera showed a black screen. I thought it was the phone's camera that was broken. I flashed the UCLE5 rooted found here: http://forum.xda-developers.com/show...7&postcount=46 and it booted up just fine. However, camera crashes when I tried to take a picture (atleast it's not a black screen now) and it randomly crashes and reboot.

When I tried to flash UCKH7, I get stuck on the "Rethink Possible" screen and did not get anywhere else.

Can anyone help me? I bought this phone for my brother and the previous owner flashed some stuffs already so I just want it back to its original state with stock before going forward with custom roms..
 
creepyncrawly
Old
#2  
Recognized Contributor
Thanks Meter 3003
Posts: 2,470
Join Date: Sep 2010

 
DONATE TO ME
Boot into recovery. With the phone off, hold all three buttons, vol+ vol- pwr, until the initial screen shows, goes black and shows again, then release buttons. Once in stock recovery, perform a wipe data/factory reset. After this, the phone should boot. Then test the camera to see if it is working correctly, and test other functions of the phone.

Does the previous owner say the phone was working fully functional before you got it?

If you get the phone to boot and working correctly, then you should flash the latest stock firmware which is UCMD8, or a good stable custom firmware. Be happy to help with that as well.
The Following 5 Users Say Thank You to creepyncrawly For This Useful Post: [ Click to Expand ]
 
nomoney4me
Old
#3  
Member - OP
Thanks Meter 7
Posts: 32
Join Date: Feb 2014
I performed the wipe in the stock recovery and it is stuck at the "Rethink Possible" screen. Only time that I got it to boot was to load the UCLE5. UCKK6 and UCKH7 didn't boot for me. I will try the UCMD8 but I don't understand why 1 stock would boot while the other one didn't.

Previous owner said it was working okay for him but he didn't know about the phone being rooted and made some kind of update or changes to the phone (software wise). I'm guessing he flashed it weirdly or something like that. I saw the count as 25 when I got into the "download recovery" portion to flash UCLE5 through ODIN. Maybe he flashed it wrongly and it has messed something up.
 
creepyncrawly
Old
#4  
Recognized Contributor
Thanks Meter 3003
Posts: 2,470
Join Date: Sep 2010

 
DONATE TO ME
Since a wipe data/factory reset will not clear the problem, it is safe to assume that there is some issue with memory. Since your were able to get the phone to boot at least once, but it was not functioning normally, it is fairly safe to assume that the memory is not permanently damaged. Based on these assumptions, I would guess that there may be nand read/write corruption. My reasoning may be incorrect, but it is sensible to try to clear the nand r/w corruption next to see if that will clear up the issues.


Instructions to clear nand read/write corruption. It is critical to follow these steps in order.

Odin3 v1.85 is recommended.

Perform a wipe data/factory reset both before, and after if needed.

1) Download the Tar version of Siyah 2.6.14 Kernel. Flash it in PDA Without ticking Re-Partitioning

2) Flash the Tar.md5 of the full stock Gingerbread distribution from the Download Repository, I777UCKH7 including the bootloaders and everything, in the PDA slot.

3) If that is successful you are done. If it is not, then:

4) Download the SBL Bootloader from the Download Repository. Flash it as PDA in ODIN, without ticking Re-Partitioning. (Please observe normal bootloader flashing caution.)

5) Flash the Kernel, as in step 1.

6) Flash the full stock Gingerbread distribution, as in step 2.
The Following 2 Users Say Thank You to creepyncrawly For This Useful Post: [ Click to Expand ]
 
nomoney4me
Old
(Last edited by nomoney4me; 24th April 2014 at 07:22 AM.) Reason: Adding error message.
#5  
Member - OP
Thanks Meter 7
Posts: 32
Join Date: Feb 2014
I followed all of your steps and it seems that I am still at the "Rethink Possible" screen. Even after flashing and wiping everything according to your directions.
I downloaded the "I777UCKH7-REV02-home-low-CL503881.tar.md5.7z" which I assumed was the full UCKH7 that you mentioned in your post. After flashing and wiping, it still hangs. I flashed the "I777 UCKH7 sbl.tar" and repeated step 1 and 2, wiped and it still hangs.

When I am doing a "wipe data/factory reset" I see an error under "Appling Multi-CSC".

This is what I see,

Quote:
Installing Multi-CSC
Can't access to '/system/csc/ATT/system/'.
Successfully applied multi-CSC
Does this have anything to do with the hanging at the boot screen?
 
creepyncrawly
Old
#6  
Recognized Contributor
Thanks Meter 3003
Posts: 2,470
Join Date: Sep 2010

 
DONATE TO ME
Quote:
Originally Posted by nomoney4me View Post
Does this have anything to do with the hanging at the boot screen?
I'm not sure. Most of what I know about this phone is gained from observation of the information that people have posted in these forums over the past two and a half years. I haven't seen an issue exactly like yours, as far as I can remember. There was one case where the phone would boot into the system, but not function properly. When it was sent to Mobile Tech Videos for jtag repair, it was found to have damaged emmc memory. I just don't know whether your issue is similar to that one or not. Any further advice is beyond the scope of my understanding.

What I have seen happen a few times is that if a person keeps trying to get the phone working, eventually some operation (flash or whatever) works differently and the phone then works. This would indicate trying different equipment, as in different pc, different cable, etc. I know that the flash is completing successfully so I don't know if this is irrelevant advice or not.

Another thing to try could be re-partitioning the memory when you flash. There is an I777 pit in the download repository. I have no experience with using it, but I remember at least two cases where a phone was recovered by flashing the pit. In one case, flashing the pit with the firmware the first time didn't clear the problem, but then flashing the firmware again worked. Flashing the pit is generally considered risky, especially if you don't know exactly what the correct steps are, but at this point, what is there to lose?
The Following User Says Thank You to creepyncrawly For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes