Microsoft To Invest in Cyanogen’s Future OS War?

Reports indicate that Microsoft is investing inthe rogue Android forker Cyanogen. The … more

Microsoft Releases Final Builds of Office for Android

Late last year, Microsoft released a preview of Office for Android, initially as an … more

Samsung Cutting Bloat, Trimming TouchWiz

Reports keep iterating over the rumors that Samsung has been trimming down TouchWiz for its upcoming … more

Google Giving Away Inbox Invites for the Next 24 Hours

Google’s biggest email rethink since the launch of Gmail, Inbox, was launched as … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Xperia Mini ST15i Restart Loop After Turning Bluetooth On

OP XPMSU

16th April 2014, 02:06 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2014
Today I wanted to send a PDF using "ES File Explorer" to somebody and just when I confirmed the "Turn on Bluetooth?" message my Xperia Mini ST15i restarted and now it's in a restarting loop. How can I solve the problem? I also don't want to lose the data on my phone memory, and I don't have any backups.

Android Version: 4.0.4 (Stock/Official Firmware) (I've been using it for more than a year and I've had no problem before this at all...)
16th April 2014, 02:14 PM   |  #2  
vishnureddy_g's Avatar
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Dec 2013
Donate to Me
More
Quote:
Originally Posted by XPMSU

Today I wanted to send a PDF using "ES File Explorer" to somebody and just when I confirmed the "Turn on Bluetooth?" message my Xperia Mini ST15i restarted and now it's in a restarting loop. How can I solve the problem? I also don't want to lose the data on my phone memory, and I don't have any backups.

Android Version: 4.0.4 (Stock/Official Firmware) (I've been using it for more than a year and I've had no problem before this at all...)

Hold down volume up+home button or power button to hard reset your mobile,
then everything works fine if it was a software issue.
16th April 2014, 07:37 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2014
Quote:
Originally Posted by vishnureddy_g

Hold down volume up+home button or power button to hard reset your mobile,
then everything works fine if it was a software issue.

It's a known unsolved bug in Xperia Minis and as I said I do not want to lose my data.
17th April 2014, 12:18 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2014
The problem is solved. I didn't do anything, I just plugged in the charger and played with the power button a bit and the Boot loop is gone.
17th April 2014, 04:58 PM   |  #5  
fundre's Avatar
Senior Member
Thanks Meter: 135
 
447 posts
Join Date:Joined: Dec 2010
Donate to Me
More
If next time it bootloops again, try wipe dalvik cache. Boot, then wipe bluetooth pairing also using titanium backup. Don't pair with the last device you tried to, because it will go bootloop again (for me). Well, at least this is how I solve my bluetooth problem on my mini pro

Sent from my Xperia Mini Pro using Tapatalk
The Following User Says Thank You to fundre For This Useful Post: [ View ]
24th April 2014, 10:45 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2014
Quote:
Originally Posted by fundre

If next time it bootloops again, try wipe dalvik cache. Boot, then wipe bluetooth pairing also using titanium backup. Don't pair with the last device you tried to, because it will go bootloop again (for me). Well, at least this is how I solve my bluetooth problem on my mini pro

Sent from my Xperia Mini Pro using Tapatalk



The problem of going into restart loop has come up again, but I did not turn on the Bluetooth, I just restarted the phone because it was working slow and now it's in a Restart Loop once again... How can I wipe the dalvik cache? (My phone is NOT rooted, by the way)
25th April 2014, 02:28 AM   |  #7  
fundre's Avatar
Senior Member
Thanks Meter: 135
 
447 posts
Join Date:Joined: Dec 2010
Donate to Me
More
Well you can't, you have to install recovery to do that (thus, already rooted). Have you unlocked bootloader? You can try any custom kernel for stock then wipe dalvik from there. It have integrated recovery.

Sent from my Xperia Mini Pro using Tapatalk

The Following User Says Thank You to fundre For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes