Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,884 Members 52,413 Now Online
XDA Developers Android and Mobile Development Forum

[Q] NOTE 2 - Please help ! just a small doubt

Tip us?
 
hackerh2
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2012
Phone [Q] NOTE 2 - Please help ! just a small doubt

My device:- GT-N7100 ( Galaxy Note 2 international Version)

I am currently using Omega 18v (Android 4.1.2)

I would like to upgrade my omega rom to any other custom 4.4.2 kit kat rom..

Now my question is..

1) Can i flash rom directly from 4.1.2 to new downloaded 4.4.2 rom
{ I believe that first we have to upgrade android to STOCK 4.3 and then i need to install 4.4.2 right.. }
Please correct me if i wrong.

2) If I take my 4.1.2 android nand backup using philz recovery..
and then i will install 4.4.2 rom..

Now after installing 4.4.2 can i able to restore my previous backup ie.. 4.1.2
{ I saw some threads and posts that we cannot downgrade our rom from 4.4.2 to 4.1.2..}

Please solve my questions.
sorry for my bad english..
 
singhpratik87
Old
#2  
singhpratik87's Avatar
Senior Member
Thanks Meter 1,580
Posts: 2,641
Join Date: Sep 2010
Quote:
Originally Posted by hackerh2 View Post
My device:- GT-N7100 ( Galaxy Note 2 international Version)

I am currently using Omega 18v (Android 4.1.2)

I would like to upgrade my omega rom to any other custom 4.4.2 kit kat rom..

Now my question is..

1) Can i flash rom directly from 4.1.2 to new downloaded 4.4.2 rom
{ I believe that first we have to upgrade android to STOCK 4.3 and then i need to install 4.4.2 right.. }
Please correct me if i wrong.

2) If I take my 4.1.2 android nand backup using philz recovery..
and then i will install 4.4.2 rom..

Now after installing 4.4.2 can i able to restore my previous backup ie.. 4.1.2
{ I saw some threads and posts that we cannot downgrade our rom from 4.4.2 to 4.1.2..}

Please solve my questions.
sorry for my bad english..
Yes you can directly flash 4.4.2 even if you are coming from 4.1.2 ROM,only thing you'd need is MJ5 bootloader (it's the last known bootloader that is KNOX free and works perfectly with 4.3 and 4.4.2 Touch wiz rom as well 4.4 AOSP ROM .You need MJ5 bootloader basically to have Wifi Working.Some people managed to get it working by staying on old bootloader and only flashing Dr.Ketan's wifi fix but in either case you don't need to upgrade to official 4.3 to flash 4.4.2.If you upgrade to stock 4.3 from samsung you will have Knoxed bootloader which will prevent downgrading to 4.1.2.So if you think you'd ever want to go back to 4.1.2 ROM then you shouldn't upgrade to stock 4.3 and just flash custom roms (after flashing the mj5 bootloader).I can provide you download link and instructions for MJ5 bootloader which can be flashed after upgrading your ROM to 4.3 or 4.4.2.Make sure you have a backup of your 4.1.2 ROM along with EFS PARTITION(that's a must) and then proceed ahead with flashing new ROMS.

MJ5 Bootloader download link

How to flash Bootloader
The Following 2 Users Say Thank You to singhpratik87 For This Useful Post: [ Click to Expand ]
 
hackerh2
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Oct 2012
Thumbs up thanks dude. .!!

Thanks for ur rply..
And also thanks for the link..

And one more question. . If I dint like the 4.4.2 rom can I downgrade using my 4.1.2 nand backup.? Even though if I flash mj5 bootloader
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes