ToqAN Fixes Android 5.0 Notification Bug on Qualcomm Toq

The Qualcomm Toq is probably one of the lesser known smartwatches on the market … more

How to Root and Unlock the Google Nexus 6 on a Mac – XDA TV

In the past, XDA Developer TV Producer droidmodd3rx has shown you how to … more

Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

D803 KitKat Baseband is Broken in Stock ROMs, 4G DOES NOT EQUAL LTE

OP autom8r

23rd April 2014, 09:55 PM   |  #1  
OP Senior Member
Thanks Meter: 119
 
440 posts
Join Date:Joined: Aug 2010
More
Hi all,
This is a thread for d803 owners to discuss how we're going to get LTE supported in KitKat.

Right now, if you flash the popular KK_Baseband floating around, you'll get "4G" after either deleting lteconfigs.apk, or tweaking your build.prop (depending on your ROM). So don't expect "4G" right off the bat, however, even after doing all necessary tweaks, you'll likely find what I found:

"4G" is not 4G, it's HSPA+ in desguise. You can tell by running speed tests (and also noting that the Network always reverts to GSM/WCDMA), they are all within HSPA+ speeds. Reverting back to JB, and running the same speed tests in the same areas results in MUCH faster speeds as it's true LTE. Meaning: 4G does not equal LTE.

Now, I know what you're thinking, "this guys a newb and didn't do the tweaks needed". No, that's not the case, I did all the tweaks, I tried this on CloudyFlex, CloudyStock and even the Rogers KK ROM floating around, all were stuck on GSM/WCDMA with "4G", which is really HSPA+.

So this being said, there appears to be no way to run a custom stock ROM, with LTE, I hope I'm wrong.

Cheers
24th April 2014, 01:05 AM   |  #2  
deadgiveaway's Avatar
Senior Member
Thanks Meter: 25
 
182 posts
Join Date:Joined: Apr 2014
Make sure you hve the right lte apn created and selected in apn settings , next forget about the icon , most roms are gonna say 4g , but check in networks settings if it says lte if it does your getting lte

Click image for larger version

Name:	uploadfromtaptalk1398294197931.jpg
Views:	234
Size:	56.2 KB
ID:	2704883

These are my apn settings
Click image for larger version

Name:	uploadfromtaptalk1398294275131.jpg
Views:	224
Size:	98.1 KB
ID:	2704885Click image for larger version

Name:	uploadfromtaptalk1398294283502.jpg
Views:	205
Size:	103.3 KB
ID:	2704886

Sent from my LG-D803 using xda app-developers app
The Following User Says Thank You to deadgiveaway For This Useful Post: [ View ]
24th April 2014, 07:52 AM   |  #3  
OP Senior Member
Thanks Meter: 119
 
440 posts
Join Date:Joined: Aug 2010
More
Thanks, that worked, however 4g is not lte, I now get actual lte in the status bar, thanks!
Last edited by El Daddy; 29th April 2014 at 12:05 AM.
24th April 2014, 09:54 AM   |  #4  
TheHaso's Avatar
Senior Member
Thanks Meter: 514
 
1,643 posts
Join Date:Joined: Feb 2012
More
On my d802 442 the lte option is now gone, and in hidden menu it says not supported. The only available is gsm and wcdma
Any ideas?

Sent from my LG-D802 using XDA Premium 4 mobile app
24th April 2014, 04:56 PM   |  #5  
Senior Member
Flag Kitchener
Thanks Meter: 139
 
1,305 posts
Join Date:Joined: Feb 2009
More
4g is LTE in configs that use US ROM base because they use that icon for the ROM instead of LTE.. Hspa has the H icon but if you check the network status screen it will show hspap... I have LTE working perfectly on my bell d803 with cloudypro2
Last edited by danial.aw; 24th April 2014 at 06:19 PM.
24th April 2014, 08:00 PM   |  #6  
deadgiveaway's Avatar
Senior Member
Thanks Meter: 25
 
182 posts
Join Date:Joined: Apr 2014
Quote:
Originally Posted by TheHaso

On my d802 442 the lte option is now gone, and in hidden menu it says not supported. The only available is gsm and wcdma
Any ideas?

Sent from my LG-D802 using XDA Premium 4 mobile app

This⬆

Sent from my LG-D803 using xda app-developers app
25th April 2014, 02:10 PM   |  #7  
Senior Member
Thanks Meter: 60
 
239 posts
Join Date:Joined: Jan 2011
More
You know 4g means lte for international Rom, only north America use 4g as hspa. Whenever you flash a custom Rom, they are mostly base on international Rom. So the 4g is actually mean lte. You can also check the mobile network type in setting as what deadgiveaway show.

Sent from my SGP311 using XDA Premium 4 mobile app
The Following User Says Thank You to athris For This Useful Post: [ View ]
25th April 2014, 07:41 PM   |  #8  
Senior Member
Flag Kitchener
Thanks Meter: 139
 
1,305 posts
Join Date:Joined: Feb 2009
More
Quote:
Originally Posted by deadgiveaway

This⬆

Sent from my LG-D803 using xda app-developers app

Try to change target country in your build prop if you are running a custom room... Once I set mine to CA, LTE has been working fantastic
25th April 2014, 07:44 PM   |  #9  
deadgiveaway's Avatar
Senior Member
Thanks Meter: 25
 
182 posts
Join Date:Joined: Apr 2014
Yea but thats just for icon ...

Sent from my LG-D803 using xda app-developers app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes