Google Maps on S5

131 posts
Thanks Meter: 11
By MurdockBaracus, Senior Member on 24th April 2014, 10:25 PM
Post Reply Subscribe to Thread Email Thread
Anyone else having problems with Gmaps? It will work for me on one route but on the next, it will try to start me from my last starting point or some random street 50 miles away. Rebooted and still had the same problem. Had to install Waze and that worked instantly so I'm guessing it's not the GPS hardware.

Sent from my SM-G900T using XDA Premium 4 mobile app
24th April 2014, 11:16 PM |#2  
gwojo22's Avatar
Senior Member
Flag Philadelphia
Thanks Meter: 31
Has the same problem. Cleared the data, uninstalled the update then reinstalled from play store. All is working.

Sent from my SM-G900T using Tapatalk
The Following User Says Thank You to gwojo22 For This Useful Post: [ View ]
25th April 2014, 02:19 AM |#3  
Senior Member
Flag Around
Thanks Meter: 47
Used it a few times on mine and had worked okay.
I will try some more.

Sent from my HTC One S using XDA Premium 4 mobile app
25th April 2014, 07:27 AM |#4  
sg3love's Avatar
Flag Torrance
Thanks Meter: 8
Google maps has been buggy lately, BUT on top of that ever since the 4.4 kikat update for my note 3, s4, and s5 my google maps/gps has been slightly off and acting funky...Delayed somehow..
25th April 2014, 02:48 PM |#5  
Thanks Meter: 3
I haven not noticed any issues with my gmaps so far though I don't use it often.

I would going to just suggest using waze, it uses more battery but I think it is worth it.
25th April 2014, 08:43 PM |#6  
MurdockBaracus's Avatar
OP Senior Member
Flag So Cal
Thanks Meter: 11
When maps goes bad it goes really bad. Even after clearing the cache and uninstall, I don't think I can trust it.

Sent from my SM-G900T using XDA Premium 4 mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes