Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,020 Members 41,086 Now Online
XDA Developers Android and Mobile Development Forum

[Q] How To Disable Capacitive Button Lights? (Unsolved)

Tip us?
 
JediN1nja
Old
(Last edited by JediN1nja; 26th April 2014 at 01:45 PM.) Reason: Changed header to display unsolved
#1  
JediN1nja's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Nov 2011
Question [Q] How To Disable Capacitive Button Lights? (Unsolved)

Hi Awesome People,

I am currently running Slim-4.4.2.build.4.6-WEEKLY-3823 on my SM-n9005 and I've enabled the NavBar and disabled (or rather re-assigned the capacitive buttons to none) but I can't for the live of me seem to find a way (NOTE 3 compatible) to disable the capacitive button lights.

I can flash custom roms and etc (duh) but I am by no means a developer. And after some looking around I managed to find that if I rename the file "lights.MSM8974.so" (/system/lib/hw) to something like "lights.MSM8974.so.bkp" it will disable the lights but then auto screen brightness doesn't work. So the solution should be in that file, right?

So can anyone help me with disabling only the capacitive button lights? Or can I do a workaround in the build.prop file?

Thanks in advance!
 
ShadowLea
Old
#2  
ShadowLea's Avatar
Senior Member
Thanks Meter 737
Posts: 3,370
Join Date: Dec 2010
Location: Enschede, The Netherlands
You are overthinking it...

Click image for larger version

Name:	Screenshot_2014-04-25-11-30-06.png
Views:	64
Size:	202.9 KB
ID:	2707679

Settings --> Device --> Display --> Touch Key Light Duration --> Always Off.
SM-N9005 International Galaxy Note 3, DBT NB7 Stock
SM-G900F International Galaxy S5, PHN NCE Stock
SM-P905 NotePro 12.2 LTE Black, DBT NC3 Stock

The person who says it cannot be done should not interrupt the person who is doing it. –Chinese Proverb

Never underestimate the power of stupid people in large groups.

The simplest solutions are often the cleverest. They are also usually wrong.
 
JediN1nja
Old
#3  
JediN1nja's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Nov 2011
Quote:
Originally Posted by ShadowLea View Post
You are overthinking it...

Attachment 2707679

Settings --> Device --> Display --> Touch Key Light Duration --> Always Off.
Thanks I've seen that solution...Except I'm running SlimKat (AOSP), that option is not there.
Neither under Setting -> Advanced Options -> Device

I've even looked for an Xposed Module and have no luck there.
 
denski101
Old
#4  
denski101's Avatar
Senior Member
Thanks Meter 70
Posts: 203
Join Date: Jan 2014
Xposed module- Gravity Box*:



*if your rom's KitKat based, you'll need Gravity Box(KK).

N9005
Don't thank me, I'm useless
The Following 2 Users Say Thank You to denski101 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes