Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

4.4.2 ROM Signal Problems.

OP leo9891

22nd April 2014, 06:32 AM   |  #1  
OP Member
Thanks Meter: 13
 
67 posts
Join Date:Joined: Jan 2012
Hey guys, I've been having problems with 4.4.2 KitKat ROMs. I'm not a newb when it comes to flashing ROMs, but whenever I install a 4.4.2 ROM, I lose my service and can't make calls or use mobile data. Now im guessing it has to do with the radio/modem. Now when it comes to radios/modems, im a newb.

Is there something different about 4.4.2 ROMs that I'm not aware about? I've flashed plenty of other ROMs before, but never had this problem.

If any of you guys can help, I would greatly appreciate it.
22nd April 2014, 06:47 AM   |  #2  
Android_Monsters's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 961
 
3,239 posts
Join Date:Joined: Feb 2012
More
Here is my about phone screen. Next to baseband it said nb4. What does yours say?

Sent from my SGH-M919 using XDA Premium 4 mobile app
Attached Thumbnails
Click image for larger version

Name:	1398142044924.jpg
Views:	102
Size:	48.9 KB
ID:	2701119  
The Following User Says Thank You to Android_Monsters For This Useful Post: [ View ]
22nd April 2014, 06:57 AM   |  #3  
Android_Monsters's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 961
 
3,239 posts
Join Date:Joined: Feb 2012
More
This is how you flash the nb4 modem.

http://forum.xda-developers.com/show....php?t=2678774

Sent from my SGH-M919 using XDA Premium 4 mobile app
The Following 2 Users Say Thank You to Android_Monsters For This Useful Post: [ View ]
22nd April 2014, 08:12 AM   |  #4  
OP Member
Thanks Meter: 13
 
67 posts
Join Date:Joined: Jan 2012
Mine says MDL. I've flashed ROMs with the NB4 Modem before and same thing. Am I supposed to flash the NB4 Modem on my Stock Rooted 4.2.2 JellyBean first, before I flash the 4.4.2 KitKat ROM?
22nd April 2014, 08:19 PM   |  #5  
Senior Member
Flag Hollywood, FL
Thanks Meter: 40
 
640 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by leo9891

Mine says MDL. I've flashed ROMs with the NB4 Modem before and same thing. Am I supposed to flash the NB4 Modem on my Stock Rooted 4.2.2 JellyBean first, before I flash the 4.4.2 KitKat ROM?

I'm having a problem that I cant figure out also. I had Beanstalk, working good.. Then someone posted a beanstalk 0414 link from AT&T . As soon as I did this I had this unresolvable problem where many (not all) cant call me or text me. I can text them and call them. When I call my cell from a desk phone, it says "one moment" or something it gets cut off then it rings my phone. I tried odin'ing nb4 and it's there but my phone just doesn't something.

I went back and odin'ed the stock rom, rerooted etc.. but no difference. same issue. Now I put the original working beanstalk on my phone and its fine other then the issues noted above. I'm in south florida, I wonder if there is an issue with NB4 down here.

PS. When I odin'ed back Stock, my Baseband was still nb4, is this correct? the modem wont change?
23rd April 2014, 03:05 PM   |  #6  
PanchoPlanet's Avatar
Senior Member
Flag Crooklyn
Thanks Meter: 697
 
2,718 posts
Join Date:Joined: Oct 2011
Donate to Me
More
Quote:
Originally Posted by leo9891

Mine says MDL. I've flashed ROMs with the NB4 Modem before and same thing. Am I supposed to flash the NB4 Modem on my Stock Rooted 4.2.2 JellyBean first, before I flash the 4.4.2 KitKat ROM?

This procedure will work, I updated my modem to NB4 before kitkat and had no data loss whatsoever after upgrading to kitkat.
Running Fenny's stock /rooted Rom with no problems. Just follow directions in op. Also running Philz touch recovery.

Pp.

sent from my P5113 using TouchPal mind control keyboard. (Beta)
The Following User Says Thank You to PanchoPlanet For This Useful Post: [ View ]
25th April 2014, 07:35 AM   |  #7  
OP Member
Thanks Meter: 13
 
67 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by PanchoPlanet

This procedure will work, I updated my modem to NB4 before kitkat and had no data loss whatsoever after upgrading to kitkat.
Running Fenny's stock /rooted Rom with no problems. Just follow directions in op. Also running Philz touch recovery.

Pp.

sent from my P5113 using TouchPal mind control keyboard. (Beta)

Installed NB4 Modem while on 4.2.2 and it worked. Thanks for everyones help. Signal seems to be the same, if not better! Now my recovery is acting wonky, but its not cause of the modem, I know that for sure.... that should be no problem though, I was just inexperienced with modems and needed help with that. Thanks!
The Following User Says Thank You to leo9891 For This Useful Post: [ View ]
25th April 2014, 06:53 PM   |  #8  
PanchoPlanet's Avatar
Senior Member
Flag Crooklyn
Thanks Meter: 697
 
2,718 posts
Join Date:Joined: Oct 2011
Donate to Me
More
Quote:
Originally Posted by leo9891

Installed NB4 Modem while on 4.2.2 and it worked. Thanks for everyones help. Signal seems to be the same, if not better! Now my recovery is acting wonky, but its not cause of the modem, I know that for sure.... that should be no problem though, I was just inexperienced with modems and needed help with that. Thanks!

I use Philz touch recovery and have had no problems.
Don't forget to hit thanks button. 😄

Pp.

sent from my P5113 using TouchPal mind control keyboard. (Beta)
25th April 2014, 07:16 PM   |  #9  
OP Member
Thanks Meter: 13
 
67 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by PanchoPlanet

I use Philz touch recovery and have had no problems.
Don't forget to hit thanks button. 😄

Pp.

sent from my P5113 using TouchPal mind control keyboard. (Beta)

I got my recovery working again. IDK what was wrong with it, just flashed a new one updated version and it's working again.
26th April 2014, 08:15 AM   |  #10  
Kriptik210's Avatar
Senior Member
Crystal River
Thanks Meter: 156
 
596 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by flipper2006

I'm having a problem that I cant figure out also. I had Beanstalk, working good.. Then someone posted a beanstalk 0414 link from AT&T . As soon as I did this I had this unresolvable problem where many (not all) cant call me or text me. I can text them and call them. When I call my cell from a desk phone, it says "one moment" or something it gets cut off then it rings my phone. I tried odin'ing nb4 and it's there but my phone just doesn't something.

I went back and odin'ed the stock rom, rerooted etc.. but no difference. same issue. Now I put the original working beanstalk on my phone and its fine other then the issues noted above. I'm in south florida, I wonder if there is an issue with NB4 down here.

PS. When I odin'ed back Stock, my Baseband was still nb4, is this correct? the modem wont change?

I live in central FL and NB4 works perfect. As for rerooting you would have to flash back to the original modem for it to change. Before you do that, try flashing a different kernel like ktoonzes

Sent from my SGH-M919 using XDA Premium 4 mobile app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes