Default [Q] Fujitsu M532 (pegatron chagall) system.img issue (custom ROM)

Hello

I'm trying to flash custom ROM for this tablet. I have made rom based on stock rom with Android Kitchen. I also received from fujitsu kernel source code, unfortunetely without make file (lol), so I can not compile it. Still, I'm using stock kernel, CWMR

Problem is that only stock ROM witch it's ORIGINAL *.img files inside works. Nothing other works - android do not boots.
I have tried in many ways and noticed folowing problems:
1. after stock ROM instalaton, I removed content of /system, and than push with adb the SAME /system folder - stops booting
2. Android Kitchen can not unpack stock system.img file
3. Ext2explorer is openig system.img, but with following error:
Code:
Partition Table Error on system.img
Invalid End of sector markerBlock size 4096, inp 8192, inodesize 256
Linux Partition found on disk 2 partition 0
Error reading Inode 0 parent inode 2.
4. The stock ROM has CUSTOM partition.
5. Flashing custom rom trought CWMR with system directory or img is not working - same result as after changing files on system parition
6. Flashing stock rom with unpacked system.img (as folder) is not workig.

This is updater-script of stock ROM:
Code:
run_program("/system/bin/mkdir", "/etc/firmware");
package_extract_file("mcuLoader","/cache/mcuLoader");
run_program("/system/bin/chmod", "777", "/cache/mcuLoader");
package_extract_file("CY8C20324_BAT_16.i2c","/etc/firmware/CY8C20324.i2c");
run_program("/cache/mcuLoader");
run_program("/system/bin/rm", "/etc/firmware/CY8C20324.i2c");
run_program("/system/bin/rm", "/cache/mcuLoader");
sleep(20);
package_extract_file("CY8C20324.i2c","/etc/firmware/CY8C20324.i2c");
package_extract_file("mcuLoader","/cache/mcuLoader");
run_program("/system/bin/chmod", "777", "/cache/mcuLoader");
run_program("/cache/mcuLoader");
unmount("/system");
mount("ext4", "EMMC", "/dev/block/platform/sdhci-tegra.3/by-name/APP", "/system");

show_progress(0.500000, 0);
package_extract_file("boot.img", "/dev/block/platform/sdhci-tegra.3/by-name/LNX");
package_extract_file("system.img", "/dev/block/platform/sdhci-tegra.3/by-name/APP");
show_progress(0.200000, 0);
package_extract_file("custom.img", "/dev/block/platform/sdhci-tegra.3/by-name/CUS");
assert(nv_copy_blob_file("blob", "/staging"));
show_progress(0.100000, 0);
What is mcuLoader and *.i2c files for?


Conclusion:
Exchanging almost every file (I menaged to delete odex files and push them again with working result) on system parition prevents booting (before adb starts, so I do not know how to get any logs).

Can anyone help solve the problem?

BTW: It would be nice to create some custom ROMs for this device - It's quite popular, as it is the same tablet as Pegatron Chagall, Olivetti Olipad 3, Siragon N4 and Realpad Bunaken