Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Cant Flash CM10 after RUU 4.3, help!

OP blindsniper96

26th April 2014, 09:59 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2013
Hello,
I am having trouble flashing cm10 again after I used ruu to go back to stock.
That was the short story, here is long story:
Last week I rooted my phone so that I could install cm10, it was the first time rooting and flashing a rom this phone.
I was successful and the rom was stable, that is until I tried to install an Xposed module. That is when things went sour
The module made my entire phone act as if it didnt have an sd card installed. (rom, bootloader, recovery, computer everything refused to recognize an sd card)
I tried reflashing cm10, twice, reverting to stock recovery then back to twrp, formatting my sd card, deleting my rom, I was about to give up, I thought my phone was permanently bricked.
Thats when I thought to use ruu to go back to stock
I tried oem locking and using ruu 4.1 and that failed every time, but then I tried ruu 4.3 and that worked the first time! Fixed my sd card problem too!
Unfortunately htc's 4.3 release is SUPER unstable and laggy.
So I decided to flash cm10 again. I unlocked my bootloader using the unlock key from htc dev I used the first time, and flashed TWRP recovery and then tried to flash cm10. I got an error, tried again got the same error. I tried to boot into the system but it was in an infinite bootloop. So not only cant I flash cm10 but I cant even root the 4.3 rom without it going into bootloop.
Note: I didnt use the "oem unlock" before unlocking bootloader command because I didnt really know If i was supposed to, I just unlocked boot loader straight from the oem locked bootloader.
This was bad, I needed my phone and I couldnt figure out how to fix this so 2 hours I gave up and tried ruu again.
It works but now Im stuck with a bad rom and no root. I cant even ruu back to stock 4.1 which is way more stable then 4.3.
Relevant info:
Phone: HTC Evo 4g lte Sprint
Recovery I was using: TWRP 2.7
Rom I was trying to flash: cyanogenmod 10.2
Unlock bootloader method: HTC dev
hboot:2.10.0000
I have always been s-on

Any help would be greatly appreciated
Last edited by blindsniper96; 26th April 2014 at 10:35 PM.
26th April 2014, 10:42 PM   |  #2  
gstanke's Avatar
Senior Member
Flag Flint
Thanks Meter: 330
 
536 posts
Join Date:Joined: Dec 2013
More
Quote:

Hello,<br />
I am having trouble flashing cm10 again after I used ruu to go back to stock. <br />
That was the short story, here is long story:<br />
Last week I rooted my phone so that I could install cm10, it was the first time rooting and flashing a rom this phone.<br />
I was successful and the rom was stable, that is until I tried to install an Xposed module. That is when things went sour<br />
The module made my entire phone act as if it didnt have an sd card installed. (rom, bootloader, recovery, computer everything refused to recognize an sd card) <br />
I tried reflashing cm10, twice, reverting to stock recovery then back to twrp, formatting my sd card, deleting my rom, I was about to give up, I thought my phone was permanently bricked.<br />
Thats when I thought to use ruu to go back to stock<br />
I tried oem locking and using ruu 4.1 and that failed every time, but then I tried ruu 4.3 and that worked the first time! Fixed my sd card problem too!<br />
Unfortunately htc's 4.3 release is SUPER unstable and laggy.<br />
So I decided to flash cm10 again. I unlocked my bootloader using the unlock key from htc dev I used the first time, and flashed TWRP recovery and then tried to flash cm10. I got an error, tried again got the same error. I tried to boot into the system but it was in an infinite bootloop. So not only cant I flash cm10 but I cant even root the 4.3 rom without it going into bootloop. <br />
Note: I didnt use the "oem unlock" before unlocking bootloader command because I didnt really know If i was supposed to, I just unlocked boot loader straight from the oem locked bootloader.<br />
This was bad, I needed my phone and I couldnt figure out how to fix this so 2 hours I gave up and tried ruu again. <br />
It works but now Im stuck with a bad rom and no root. I cant even ruu back to stock 4.1 which is way more stable then 4.3.<br />
Relevant info:<br />
Phone: HTC Evo 4g lte Sprint<br />
Recovery I was using: TWRP 2.7<br />
Rom I was trying to flash: cyanogenmod 10.2<br />
Unlock bootloader method: HTC dev<br />
hboot:2.10.0000<br />
I have always been s-on<br />
<br />
Any help would be greatly appreciated

I would recommend getting s-off. It's a lot easier to flash roms that way, also cm10 is on the old layout, because if the ruu you used you can't flash it. http://forum.xda-developers.com/show....php?t=2654590

[ROM][AOSP] CM11 & other AOSP-based ROMs that support updated partition layout check out this thread for aosp roms on the new layout. Also make sure you have the modified recovery for the new layout.

Sent from my EVO using xda app-developers app
The Following User Says Thank You to gstanke For This Useful Post: [ View ]
26th April 2014, 11:39 PM   |  #3  
Evolution_Freak's Avatar
Senior Member
Flag East Stroudsburg
Thanks Meter: 419
 
789 posts
Join Date:Joined: Jun 2013
More
Yes, I suggest going S-off as well. Look here:

http://forum.xda-developers.com/show....php?t=2498684

Also, now that you've run the 4.3 RUU, you will need the TWRP recovery found here:

http://forum.xda-developers.com/show....php?t=2639180


Sent from my Nexus 5 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes