Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,962 Members 39,676 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Camera button not working properly?

Tip us?
 
bn.op12
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Apr 2012
Default [Q] Camera button not working properly?

I was playing with the camera on my Z2 and noticed that the dedicated camera shutter button wasn't working. I press the button, it focuses, and the button on the side disappear as if it were about to take the picture, but it just stays that way until I release the button. When I release the button, no picture is taken and it unfocuses and the buttons come back.

My phone is bootloader unlocked, rooted, and I removed some things via Titanium Backup. Did I somehow remove a piece of software needed to use the button correctly?

Any help is appreciated.

Thanks.
 
Envious_Data
Old
#2  
Envious_Data's Avatar
Senior Member
Thanks Meter 670
Posts: 1,631
Join Date: Oct 2012
Location: Yaizu
Are you awear that it is a two stage button

Soft press for focus
Hard click for snap picture

When you focus the Overlay is removed for better view
You could use the onscreen buttons if this isnt the case

This could be a firmware or hardware issue
I need more details to conform


Random:
You can not remove of Firmware that manages the camera button however you can delete the camera

Unlocked bootloaders should have no affect on anything at all besides the usual bravia / x reality

Same goes for root
Devices:
Sony Xperia Z2

Roms:
Envi-Rom Z2/S
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes