Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,619 Members 46,624 Now Online
XDA Developers Android and Mobile Development Forum

Help! Phone fails to charge, repeatedly vibrates some times

Tip us?
 
Formhault
Old
(Last edited by Formhault; 26th April 2014 at 08:15 AM.)
#1  
Formhault's Avatar
Senior Member - OP
Thanks Meter 2824
Posts: 7,974
Join Date: Jun 2011
Location: X-3043
Default Help! Phone fails to charge, repeatedly vibrates some times

This morning, my phone has started to act up. It was working well last night, but now... when I put it to charge... it either:
1) doesn't do anything
2) requires the cable to be repeatedlty inserted in order to register an input
3) does accept the cable, charges for a bit, then disconnects, connects, disconnects, connects and so on

I tried with three chargers and two cables. All of which work well with other microUSB phones I have laying around.

I put my phone to charge a couple of minutes ago (with the phone facing down, figured so it may help with the contacts) and it worked for about 5 minutes. Now... it suddenly disconnected and started connecting/disconnecting again . Then, it stops disconnecting and stays connected, but not for long...
The phone IS charging for the time it's connected, as I see the percentage has gone up from 93% to 95% in all this time.

I took a tooth pick and scrubbed the inside of the microUSB port (took out a lot of dust and such). I know that's been an issue on the Galaxy Note, but here, on the S4...

I guess I'll have to turn off the phone, take an old tooth brush, dump it in alcohol, and scrub the inside of the microUSB port... that has worked on the Galaxy Note .

----------

Regardless. Anyone else... care to input your thoughts?

PS: The battery isn't swollen, and speaking of which, I have recently swapped batteries with a friend - so this battery is like brand new, manufactured in March 2014... it can't possibly be faulty .
Did my post entertain or help you? Do you hate me? Hit the THANKS button!



To all my haters
 
 
Joku1981
Old
#2  
Joku1981's Avatar
Senior Member
Thanks Meter 545
Posts: 1,803
Join Date: Jun 2012

 
DONATE TO ME
You can try to clean it. But the USB seems be ****ed. You can take a look this GUIDE for change it manually. Its easy but it need a lil time. Good luck

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
CLICK "THANKS" BUTTON IF I HELPED YA
The Following User Says Thank You to Joku1981 For This Useful Post: [ Click to Expand ]
 
Formhault
Old
#3  
Formhault's Avatar
Senior Member - OP
Thanks Meter 2824
Posts: 7,974
Join Date: Jun 2011
Location: X-3043
Quote:
Originally Posted by Joku1981 View Post
You can try to clean it. But the USB seems be ****ed. You can take a look this GUIDE for change it manually. Its easy but it need a lil time. Good luck
I cleaned it with some alcohol (more like dipped it in it ). All seems to be working now.

Something similar happened to the Note 1, where I had to do this for like 5 times before it started working again... I just didn't expect this to happen on the S4, as well...
Did my post entertain or help you? Do you hate me? Hit the THANKS button!



To all my haters
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes