Post Reply

Galaxy tab pro 8.4 dust/dead pixels

15th March 2014, 10:11 PM   |  #1  
Optimusg2x's Avatar
OP Senior Member
Chicago
Thanks Meter: 56
 
201 posts
Join Date:Joined: Apr 2011
More
My first two tab pros had 3-5 dead pixels under the screen and the current one now has 2-3 specks of dust under the screen. They were purchased from Amazon if that matters to anyone.

Has anyone else had these issues?

Sent from my SM-N900T using Tapatalk
17th March 2014, 10:42 PM   |  #2  
Optimusg2x's Avatar
OP Senior Member
Chicago
Thanks Meter: 56
 
201 posts
Join Date:Joined: Apr 2011
More
I can't be the only one

Sent from my SM-N900T using Tapatalk
18th March 2014, 01:48 AM   |  #3  
Senior Member
Thanks Meter: 16
 
260 posts
Join Date:Joined: Nov 2008
I have dust under the screen, I've bought from local retailer, Samsung repair center told me to wait for a month until they have parts to replace it.

Sent from my SM-T320 using xda app-developers app
The Following User Says Thank You to hongkongtom For This Useful Post: [ View ]
18th March 2014, 08:52 PM   |  #4  
Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Aug 2010
My first Tab Pro 8.4 had a lot of dust/smudging in one corner. I bought it from Best Buy so I took it back. The replacement is fine.
18th March 2014, 10:03 PM   |  #5  
ritchea's Avatar
Senior Member
Flag okeechobee
Thanks Meter: 52
 
287 posts
Join Date:Joined: Sep 2011
More
Not the 8.4 but 12.2 tab pro from Amazon had a problem--either a group of dead pixels or sediment beneath the digitizer not just beneath the screen. The replacement had been opened (updated os plus re-taped) apparently to be inspected by Amazon. It has no issues although, ironically, there was a lot of debris inside the box of the replacement. Each was shipped from a different distribution center.

Sent from my Nexus 7 using Tapatalk
28th March 2014, 06:28 PM   |  #6  
fusionx86's Avatar
Junior Member
Thanks Meter: 5
 
24 posts
Join Date:Joined: Oct 2013
More
I must have gotten lucky with my 8.4. My wife is on her 3rd 10.1 right now. Dead pixel on the first one and the second one had some strange issue with the screen in one spot where it was too shiny or reflective. It wasn't a dead or stuck pixel. So far the 3rd one is good.
31st March 2014, 10:09 PM   |  #7  
dorpmuller's Avatar
Member
Thanks Meter: 20
 
68 posts
Join Date:Joined: Dec 2009
Almost makes me wonder if Amazon deals with B stock items, seems most of thr complaints come from there.

Rich
1st April 2014, 04:33 AM   |  #8  
Senior Member
Thanks Meter: 107
 
799 posts
Join Date:Joined: Sep 2010
I had 2 dead pixels on my first one from best buy when they first came out. i exchanged it and knock on wood it has been perfect. luck of the draw imo
2nd April 2014, 02:23 PM   |  #9  
Member
Thanks Meter: 2
 
33 posts
Join Date:Joined: Nov 2010
Got mine from Amazon early March and it appeared to be fine. This weekend I noticed a stuck pixel, and now in process of returning it.
Pity to hear about this, given Samsung is an A-brand.
27th April 2014, 07:48 AM   |  #10  
Member
Flag Yuzhno-Sakhalinsk
Thanks Meter: 2
 
31 posts
Join Date:Joined: Apr 2012
Dust on the camera lens

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy Tab Pro 12.2, 10.1, 8.4 Q&A, Help & Troubleshooting by ThreadRank