Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,920 Members 42,812 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Android Public Class Error

Tip us?
 
haroonhaleem@yahoo.com
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
Default [Q] Android Public Class Error

Hi Every1,

I am very new to programming. I just created my first app on Eclipse ( Hello World program ). Whenever I run check on my project I get error mentioned below.

This class should be public (android.support.v7.internal.widget.ActionBarView. HomeView)

I already have "appcompat_v7" entry in my android library for my project. Please guide how to correct this error.

Regards,
Haroon
 
haroonhaleem@yahoo.com
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
Anyone plz reply

Quote:
Originally Posted by haroonhaleem@yahoo.com View Post
Hi Every1,

I am very new to programming. I just created my first app on Eclipse ( Hello World program ). Whenever I run check on my project I get error mentioned below.

This class should be public (android.support.v7.internal.widget.ActionBarView. HomeView)

I already have "appcompat_v7" entry in my android library for my project. Please guide how to correct this error.

Regards,
Haroon
 
droidshan
Old
#3  
droidshan's Avatar
Member
Thanks Meter 4
Posts: 54
Join Date: Oct 2013
Quote:
Originally Posted by haroonhaleem@yahoo.com View Post
Anyone plz reply
if you are new to programming. try to start a new project in eclipse without actionbar. ..
 
haroonhaleem@yahoo.com
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Apr 2014
I have even tried without actionbar and it gives same error.

Whenever I select minimum Required SDK to API level 8, appcompat_v7 library gets associated with it. When I run check on appcompat_v7 library I get same error. When I create project with higher API level then no appcompat_v7 library gets associated with it and no error is faced in my project. I believe this appcompat_v7 library is to provide backward compatibility and itself contains error.

Quote:
Originally Posted by droidshan View Post
if you are new to programming. try to start a new project in eclipse without actionbar. ..
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes