Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Need Help getting Kit Kat on my AT&T HTC ONE M7 please

OP jsknair

27th April 2014, 05:44 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Feb 2009
Ok, long story short - got a used M7 that was running 4.1.2 and OTA failed. Found the phone was rooted and with the help of this forum, I was able to unroot and get to 4.3. Then came the bigger problem of camera going pink/purple all over during low lights. Also, the OTA still failed.

Attempted the manual RUU update to KK using the file below:

http://www.htc1guru.com/dld/ruu_m7_u..._signed_2-exe/

Verified the MD5 and downloaded fresh set of adb/fasboot.exe. I am running Window 7 64bit but the ruu update keep stuck at the following screen:



I reinstalled the sdk, rebooted several times, cleaned registry, temp files with no success...

Following is my current bootloader information:



Can somebody please help me get to KK as am sure the pinky hue on camera is something to do with s/w.

Thanks in advance.
27th April 2014, 06:02 PM   |  #2  
nkk71's Avatar
Recognized Contributor
Flag Beirut
Thanks Meter: 3,108
 
6,256 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by jsknair

Can somebody please help me get to KK as am sure the pinky hue on camera is something to do with s/w.

No, it's hardware problem... http://forum.xda-developers.com/show....php?t=2317507

changing certain settings in camera can help reduce it, but not make it go away.
27th April 2014, 06:14 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Feb 2009
That is sad. Very sad...

Regardless, how I can get my phone to KK?
Any fix please?

Thanks.
27th April 2014, 06:26 PM   |  #4  
sharksfan7's Avatar
Senior Member
Flag San Diego
Thanks Meter: 62
 
187 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by jsknair

That is sad. Very sad...

Regardless, how I can get my phone to KK?
Any fix please?

Thanks.

There seems to be some issues with the KK RUU for some users. So use the JB 3.17.502.3 RUU instead then use the OTA to get it to KK. I just did this two days ago & it works without issue.
27th April 2014, 06:42 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Feb 2009
Quote:
Originally Posted by sharksfan7

There seems to be some issues with the KK RUU for some users. So use the JB 3.17.502.3 RUU instead then use the OTA to get it to KK. I just did this two days ago & it works without issue.

I believe that is the one I installed when I unrooted but the OTA still fails.... let me give it a try again...Thanks.
27th April 2014, 06:47 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Feb 2009
OK, I confirmed that is the RUU I downloaded and installed but the OTA fails. See below my earlier thread...

http://forum.xda-developers.com/show....php?t=2725383

Any other way around? Thanks.
27th April 2014, 06:57 PM   |  #7  
sharksfan7's Avatar
Senior Member
Flag San Diego
Thanks Meter: 62
 
187 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by jsknair

I believe that is the one I installed when I unrooted but the OTA still fails.... let me give it a try again...Thanks.

Have you tried to S-OFF yet? With HBOOT 1.55, you may be able to with Firewater. That's the setup I originally had (1.55 & 3.17.502.3) & Firewater worked with the temproot method on my first attempt. With S-OFF you have more options for updating. I used a decrypted RUU, which you can only use when S-OFF.

You may want to try that first. If you're successful at updating to KK, it'll update your HBOOT to 1.56 and then you may not be able to S-OFF.
27th April 2014, 07:07 PM   |  #8  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Feb 2009
Thank you, I'll give it a shot later today as it needs a lot of reading. I have never done that before...
27th April 2014, 07:25 PM   |  #9  
sharksfan7's Avatar
Senior Member
Flag San Diego
Thanks Meter: 62
 
187 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by jsknair

Thank you, I'll give it a shot later today as it needs a lot of reading. I have never done that before...

I know it seems daunting at first. The instructions on how to use Firewater are very clear. Just read through them carefully (including the Prerequisites) and follow them exactly. The steps aren't hard.

If Firewater works and you get S-OFF, download this decrypted JB4.3 RUU http://www.htc1guru.com/dld/ruu-zip-...decrypted-zip/ Be sure to verify the md5. I've had some issues with downloads from this site stopping before it's complete. May take a few attempts to get it.

The instructions on how to flash it is at the bottom of this page, http://www.htc1guru.com/downloads/ruu-zip-downloads/

Then try the OTA. Are you on the AT&T network? I am & was able to get the OTA by just checking for updates on the phone. If you're not on AT&T you'll need to flash it manually. Here's the thread on how to do that.
http://forum.xda-developers.com/show....php?t=2659374

Good luck.

Post Reply Subscribe to Thread

Tags
ruu
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes