Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Internet disconnects always after around 10-30 seconds since WiFi connected

OP Cullinan

28th April 2014, 12:55 AM   |  #1  
Cullinan's Avatar
OP Junior Member
Thanks Meter: 9
 
8 posts
Join Date:Joined: Dec 2012
1. I connect my phone to my router - WiFi connected, signal strength maximum, everything alright.
2. I start browsing the net.
3. After very short time (usually around 10-30 seconds, sometimes 3, sometimes 60) any web browser gives me error "Web page not available".
WiFi is still connected, but Internet isn't.
4. I turn WiFi off and then back on.
5. Go to 2.

It's very annoying and makes WiFi useless - if I want to watch a single video on YouTube, I need to restart my WiFi like 10 times while watching.
I should mention that all of my other devices work fine with this router/network.

What I've tried / done:
-all possible reboots and resets
-all possible phone wifi settings
-reconfiguration of my router and entire network
-Android Revolution HD and Cyanogenmod 10.2 ROMs

It probably isn't hardware issue as I have had my wifi hardware changed recently by official warranty service before unlocking bootloader and losing warranty. The reason for this was popular poor wifi range issue. But my problem with net disconnecting occured before as well as after the warranty service. I'm ready to buy you a few beers if you can solve this!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes