FORUMS

returned mine due to poor antenna

482 posts
Thanks Meter: 100
 
By memekmek, Senior Member on 28th April 2014, 06:51 PM
Thread Closed Subscribe to Thread Email Thread
I had to return mine today... I was loving the speed, screen, etc. however the antenna just stopped working after one week and was not able to call/text/get data. It would cut out every 30-60 seconds. It happened on my sprint htc one m8 gunmetal... anyone else have these issues? I've heard that its pretty widespread with this and the S5
 
 
28th April 2014, 06:57 PM |#2  
Senior Member
Flag Cape Cod, MA
Thanks Meter: 25
 
More
Quote:
Originally Posted by memekmek

I had to return mine today... I was loving the speed, screen, etc. however the antenna just stopped working after one week and was not able to call/text/get data. It would cut out every 30-60 seconds. It happened on my sprint htc one m8 gunmetal... anyone else have these issues? I've heard that its pretty widespread with this and the S5

Obviously something defective in the hardware of your unit. If it was a widespread issue these forums would be blowing up with dissatisfied customers. Have them replace your unit and enjoy it.
28th April 2014, 09:59 PM |#3  
Stephen's Avatar
Forum Moderator / Retired Recognized Developer
Thanks Meter: 6,489
 
More
Thread closed,

Please remember forum rules. Remember to post in existing threads were possible eg:

Build Quality Concerns

Ghost
Thread Closed Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes