Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,525 Members 39,230 Now Online
XDA Developers Android and Mobile Development Forum

Custom Rom Problem

Tip us?
 
diando
Old
#1  
Member - OP
Thanks Meter 3
Posts: 39
Join Date: May 2013
Default Custom Rom Problem

Everytime I install a 4.4.2 ROM it works fine until I power-off completely. When I turn it back on the microphone and speakers stop working.

I can restart the phone and reboot to recovery and everything is fine.

Of course my phone is a d2att. I only seem to get it working again is when I restore a Nandroid backup of the stock ROM then reinstall the custom ROM.

Can someone tell me a permanent way to solve this problem so I can power off with my custom ROM?
 
task650
Old
#2  
task650's Avatar
Recognized Developer
Thanks Meter 47,833
Posts: 21,891
Join Date: Sep 2010
Location: Portland, Oregon

 
DONATE TO ME
Quote:
Originally Posted by diando View Post
Everytime I install a 4.4.2 ROM it works fine until I power-off completely. When I turn it back on the microphone and speakers stop working.

I can restart the phone and reboot to recovery and everything is fine.

Of course my phone is a d2att. I only seem to get it working again is when I restore a Nandroid backup of the stock ROM then reinstall the custom ROM.

Can someone tell me a permanent way to solve this problem so I can power off with my custom ROM?
You really haven't given any information that would help to diagnose your issues. Without information it's pretty much impossible to help you.

1.) What ROM?

2.) Fully wipe?

3.) Have you made any modifications that could conflict?

4.) Ect...
 
diando
Old
#3  
Member - OP
Thanks Meter 3
Posts: 39
Join Date: May 2013
Quote:
Originally Posted by task650 View Post
You really haven't given any information that would help to diagnose your issues. Without information it's pretty much impossible to help you.

1.) What ROM?

2.) Fully wipe?

3.) Have you made any modifications that could conflict?

4.) Ect...
I've installed Validus, C-ROM, CM11, AOKP.

None of them seem to have sound working on restart. I've tried re-flashing 4.1.1 stock via Odin then reinstall those ROMs but it never seem to work. Still have that problem after it is turned off.

I've fully wiped the phone clean every time.

Sound on the stock ROM works fine.
 
task650
Old
(Last edited by task650; 27th April 2014 at 10:11 PM.)
#4  
task650's Avatar
Recognized Developer
Thanks Meter 47,833
Posts: 21,891
Join Date: Sep 2010
Location: Portland, Oregon

 
DONATE TO ME
Not really sure what to tell you as you seem to be one of the only users posting this type of issue as far as I can see. Maybe someone that has the same issue will chime in here.
 
diando
Old
#5  
Member - OP
Thanks Meter 3
Posts: 39
Join Date: May 2013
Quote:
Originally Posted by task650 View Post
Not really sure what to tell you as you seem to be one of the only users posting this type of issue as far as I can see. Maybe someone that has the same issue will chime in here.
Also other notes

Using the Google Experience Launcher when I use the hotword "OK Google" the beep sound is scratchy.
 
diando
Old
(Last edited by diando; 29th April 2014 at 05:21 AM.)
#6  
Member - OP
Thanks Meter 3
Posts: 39
Join Date: May 2013
Made another discovery, @task650, I flashed the stock recovery while running C-ROM and wiped the cache and it restored sound every time - though wiping the cache in CWM did nothing. I'm going to try TWRP now.

EDIT
--

TWRP wipe doesn't work but it does seems like there's a problem with how the cache works on my phone. Hopefully 4.4.3 based roms won't have the same issues but I will stick to stock recovery for now.

Is there any way to get a CWM flashable zip of the stock recovery or nandroid file?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Create a Simple Custom Launcher from Scratch

When you are starting your journey intoany sort of development, it’s never easy at the … more

MediaTek Continues Steps Towards Being Developer-Friendly

Not too long ago MediaTek was very closed off towards the mobile developer … more

Sony PS4 Remote Play Ported to All Android Devices

Im pretty sure that every informed gamer out there perked their ears up when Sony came out … more