Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,428 Members 47,164 Now Online
XDA Developers Android and Mobile Development Forum

LG app development - Excisting Qslide news

Tip us?
 
Life Engineer
Old
#1  
Life Engineer's Avatar
Senior Member - OP
Thanks Meter 218
Posts: 1,041
Join Date: Jun 2010
Location: Jounieh
Thumbs up LG app development - Excisting Qslide news

Hey all!

Sorry for posting this in here, in case it's not the perfect place to do so.
As you know Qslide is LG's way to do multitasking, consisting on windows (Halo like) that can be minimized and even transparent.
Originally, it only supported stock LG apps, but now things has taken a beautiful path.

See here for the news:
http://www.phonearena.com/news/LG-to...eature_id51906

and here for details:
http://developer.lge.com/resource/mo...yTypeCode=ANRS

I always wanted that because with default apps, it felt useless!

Please spread the news so it can reach the maximum number of developers!
LG G2 D802 - CPU binned 3
Current ROM: Spiderio 380dpi ROM v1.2b android 4.4.2
Current Kernel: Stock

Previously owned devices: Nokia N96>HTC HD2>HTC DESIRE HD>SG NEXUS>HTC SENSATION XE>SGSII>SGSIII>LG NEXUS 4>LG G2
Damn! I think I got it... I got ORD => Obsessive ROM-updating Disorder => Click here!
If I helped in any means please click the "Thanks" button and that will do!
 
doink123
Old
#2  
Member
Thanks Meter 46
Posts: 74
Join Date: Sep 2010
Quote:
Originally Posted by Life Engineer View Post
Hey all!

Sorry for posting this in here, in case it's not the perfect place to do so.
As you know Qslide is LG's way to do multitasking, consisting on windows (Halo like) that can be minimized and even transparent.
Originally, it only supported stock LG apps, but now things has taken a beautiful path.

See here for the news:
http://www.phonearena.com/news/LG-to...eature_id51906

and here for details:
http://developer.lge.com/resource/mo...yTypeCode=ANRS

I always wanted that because with default apps, it felt useless!

Please spread the news so it can reach the maximum number of developers!

QLight plugin released. It integrates Tiny Flashlight v5.0 (beta) with QSlide Apps. You can start the flashlight directly from your notifications screen. More info: http://forum.xda-developers.com/show....php?t=2560625
And even more info: https://plus.google.com/110628468453...ts/f8XqPDSffj2


The Following User Says Thank You to doink123 For This Useful Post: [ Click to Expand ]
 
Life Engineer
Old
#3  
Life Engineer's Avatar
Senior Member - OP
Thanks Meter 218
Posts: 1,041
Join Date: Jun 2010
Location: Jounieh
Quote:
Originally Posted by doink123 View Post
QLight plugin released. It integrates Tiny Flashlight v5.0 (beta) with QSlide Apps. You can start the flashlight directly from your notifications screen. More info: http://forum.xda-developers.com/show....php?t=2560625
And even more info: https://plus.google.com/110628468453...ts/f8XqPDSffj2
Great Job dev! Keep it up and bring us more goodies
Thanks!
LG G2 D802 - CPU binned 3
Current ROM: Spiderio 380dpi ROM v1.2b android 4.4.2
Current Kernel: Stock

Previously owned devices: Nokia N96>HTC HD2>HTC DESIRE HD>SG NEXUS>HTC SENSATION XE>SGSII>SGSIII>LG NEXUS 4>LG G2
Damn! I think I got it... I got ORD => Obsessive ROM-updating Disorder => Click here!
If I helped in any means please click the "Thanks" button and that will do!
 
doink123
Old
#4  
Member
Thanks Meter 46
Posts: 74
Join Date: Sep 2010
One question.. right now the QSlide Apps SDK requires API level 17, but my QLight plugin does not include the SDK itself. It uses the QSlide apps shortcut functionality only. Can this functionality be used on lower API levels? I didn't find this information in the documentation. It would be great if I can make my app available on older versions of QSlide.
 
blazewit
Old
#5  
blazewit's Avatar
Senior Member
Thanks Meter 115
Posts: 261
Join Date: Jun 2010
Location: Madison

 
DONATE TO ME
Quote:
Originally Posted by doink123 View Post
One question.. right now the QSlide Apps SDK requires API level 17, but my QLight plugin does not include the SDK itself. It uses the QSlide apps shortcut functionality only. Can this functionality be used on lower API levels? I didn't find this information in the documentation. It would be great if I can make my app available on older versions of QSlide.
Hey quick question, since the qslide sdk does include a simple "shortcut" function, would it be posible to make a simple qlite type app but let the end user direct what app the plugin launches? Basically use the shortcut function as a means to alow any app to be put in the qslide area.
the definition of open: “mkdir android ; cd android ; repo init -u git:// android.git.kernel.org/platform/manifest.git ; repo sync ; make" .....gangsta mike drop...
 
doink123
Old
#6  
Member
Thanks Meter 46
Posts: 74
Join Date: Sep 2010
Quote:
Originally Posted by blazewit View Post
Hey quick question, since the qslide sdk does include a simple "shortcut" function, would it be posible to make a simple qlite type app but let the end user direct what app the plugin launches? Basically use the shortcut function as a means to alow any app to be put in the qslide area.
Yes, this is possible, but the app will be launched as a standard application and will not use QSlide's floating windows.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...