Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] 3G suddenly started to drain battery

OP tmsx

6th April 2014, 10:32 PM   |  #1  
OP Junior Member
Flag Kaszb
Thanks Meter: 0
 
10 posts
Join Date:Joined: Apr 2010
More
Hello,
about one week ago I noticed that battery in my N1 was empty in 5-6 hours after charging.
My first though was that 4 years battery is just old. I bought new one (1800 mAh). Unfortunately it didn't fix the problem.
Battery stats didn't show anything interesting. So to check what exactly drain my battery I had to disable one by one GPS, WiFi and finally 3G. I noticed that if phone uses 2G network then power consumption is normal. But regardless of GPS, WiFi, BT etc.. seems that only 3G is guilty.

My question is why after 4 years of using N1 suddenly 3G drains my battery? I have turned it on since the begining.

I already tried:
  • buy new battery
  • remove battery stats
  • full wipe

ROM: 2.3.7 GB by euroskank CM7.2-20131028.2353-N1 FuZZ_

PS. It shouldn't be connected, but at that time I started to use my N1 to deploy application which I develop. It uses localization (GPS/network) and Google Play Services.
29th April 2014, 11:19 AM   |  #2  
OP Junior Member
Flag Kaszb
Thanks Meter: 0
 
10 posts
Join Date:Joined: Apr 2010
More
It seems that something in 3G module is broken. It can takes 40% battery in 2 hours.
In the same time 2G takes 1%.
Strange... 4 years it worked very well till now
Last edited by tmsx; 29th April 2014 at 11:27 AM.
Post Reply Subscribe to Thread

Tags
drain battery
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes