Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

A2DP Bluetooth Issues

OP JT114881

30th April 2014, 02:34 AM   |  #1  
JT114881's Avatar
OP Senior Member
Flag Worcester
Thanks Meter: 29
 
135 posts
Join Date:Joined: Feb 2011
More
I have a Bluetooth headset that supports A2DP and Phone audio (Sena SMH10R). Phone/Call audio works and always works. A2DP audio works with music and other 'continuous' streams. The problem happens when I use Google Nav or other software like this that push audio over A2DP every now and then. When I pair the headset to the phone and start Google Nav, it will work for the first few turns, then it will stop working. I am unable to get this working again unless I: reboot the phone, toggle the "Media Audio" option in Bluetooth, or toggle Bluetooth on and off.

During the state of A2DP being broken (before I fix it with one of the three methods above) phone/call audio to the headset still works. However during this time, no A2DP audio works (music, navigation, notifications).

The only workaround to have navigation is to play music in the background, then launch Google Nav. Google Nav will interrupt the music every time it needs to provide me with directions, however this is less than ideal as I don't always want to listen to music.

I originally thought this might be a TTS issue, so I tried different TTS software (Ivona for example) however this did not fix the issue. Using a different Navigation software like Waze also did not fix the issue.

I have 2 HTC one M8's and I have tested both with stock unmodified (Sense 6) as well as the fully converted GPE. I have also tested this with two of the same headsets. Headsets have latest firmware, but I tested with previous versions as well.

Any ideas what I can do to get this working correctly without having to stream music?

Thanks guys!
30th April 2014, 05:07 AM   |  #2  
an0ther's Avatar
Senior Member
Thanks Meter: 214
 
594 posts
Join Date:Joined: Sep 2013
Blank audio track on repeat?

Sent from my HTC One_M8 using XDA Premium 4 mobile app
30th April 2014, 05:08 AM   |  #3  
JT114881's Avatar
OP Senior Member
Flag Worcester
Thanks Meter: 29
 
135 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by an0ther

Blank audio track on repeat?

Sent from my HTC One_M8 using XDA Premium 4 mobile app

That would work but I was hoping for more of a fix rather than a workaround.
30th April 2014, 05:32 AM   |  #4  
an0ther's Avatar
Senior Member
Thanks Meter: 214
 
594 posts
Join Date:Joined: Sep 2013
Quote:
Originally Posted by JT114881

That would work but I was hoping for more of a fix rather than a workaround.

I was browsing and found someone had a similar problem as you. Try "a2dp volume" on play store. After reading description it sounds like it might work for you.

Sent from my HTC One_M8 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes