Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Stop Your Screen From Turning Off with KeepItOn

We all know the feeling of reading a news article orrather longdocument, when our screen … more

The XDA LG QPair Developer Challenge Voting Has Begun!

It seems like it was just yesterday that weannounced that we had paired up with LGto … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Broken GPS after ND3 update

OP effry

29th April 2014, 11:09 PM   |  #1  
effry's Avatar
OP Senior Member
Flag Naples
Thanks Meter: 58
 
284 posts
Join Date:Joined: Mar 2011
More
hi all, as the title says my gps is broken after upgrading through odin. Neither restoring NC2 or flashing cm11 solved the issue. Can anyone tell me if is an hadware problem? logcat keep continously spamming this while searching location

E/LocSvc_ApiV02(856): D/virtual void LocApiV02::eventCb(locClientHandleType, uint32_t, locClientEventIndUnionType):2551]: event id = 36
E/LocSvc_ApiV02(856): D/Reporting postion from V2 Adapter
E/LocSvc_utils_q(856): D/msg_q_snd: Sending message with handle = 0x792A50B0
E/LocSvc_utils_ll(856): D/linked_list_add: Adding to list data_obj = 0x792A50B0
E/LocSvc_utils_q(856): D/msg_q_snd: Finished Sending message with handle = 0x792A50B0
E/LocSvc_utils_ll(856): D/linked_list_remove: Removing from list
E/LocSvc_utils_q(856): D/msg_q_rcv: Received message 0x792A50B0 rv = 0
E/LocSvc_MsgTask(856): D/MsgTask::loop() 865 listening ...
E/LocSvc_utils_q(856): D/msg_q_rcv: Waiting on message
E/LocSvc_utils_q(856): D/msg_q_snd: Sending message with handle = 0x88B7F318
E/LocSvc_utils_ll(856): D/linked_list_add: Adding to list data_obj = 0x88B7F318
E/LocSvc_utils_q(856): D/msg_q_snd: Finished Sending message with handle = 0x88B7F318
E/LocSvc_utils_ll(856): D/linked_list_remove: Removing from list
E/LocSvc_utils_q(856): D/msg_q_rcv: Received message 0x88B7F318 rv = 0
E/LocSvc_MsgTask(856): D/MsgTask::loop() 866 listening ...
E/LocSvc_utils_q(856): D/msg_q_rcv: Waiting on message
E/LocSvc_ApiV02(856): D/void LocApiV02::reportPosition(const qmiLocEventPositionReportIndMsgT_v02*):2004]: Ignoring position report with sess status = 7, fix id = 119
E/LocSvc_ApiV02(856): I/<--- void globalEventCb(locClientHandleType, uint32_t, locClientEventIndUnionType, void*) line 90 QMI_LOC_EVENT_POSITION_REPORT_IND_V02
30th April 2014, 05:58 AM   |  #2  
xdm9mm's Avatar
Senior Member
Thanks Meter: 64
 
300 posts
Join Date:Joined: Dec 2013
More
Quote:
Originally Posted by effry

hi all, as the title says my gps is broken after upgrading through odin. Neither restoring NC2 or flashing cm11 solved the issue. Can anyone tell me if is an hadware problem? logcat keep continously spamming this while searching location

E/LocSvc_ApiV02(856): D/virtual void LocApiV02::eventCb(locClientHandleType, uint32_t, locClientEventIndUnionType):2551]: event id = 36
E/LocSvc_ApiV02(856): D/Reporting postion from V2 Adapter
E/LocSvc_utils_q(856): D/msg_q_snd: Sending message with handle = 0x792A50B0
E/LocSvc_utils_ll(856): D/linked_list_add: Adding to list data_obj = 0x792A50B0
E/LocSvc_utils_q(856): D/msg_q_snd: Finished Sending message with handle = 0x792A50B0
E/LocSvc_utils_ll(856): D/linked_list_remove: Removing from list
E/LocSvc_utils_q(856): D/msg_q_rcv: Received message 0x792A50B0 rv = 0
E/LocSvc_MsgTask(856): D/MsgTask::loop() 865 listening ...
E/LocSvc_utils_q(856): D/msg_q_rcv: Waiting on message
E/LocSvc_utils_q(856): D/msg_q_snd: Sending message with handle = 0x88B7F318
E/LocSvc_utils_ll(856): D/linked_list_add: Adding to list data_obj = 0x88B7F318
E/LocSvc_utils_q(856): D/msg_q_snd: Finished Sending message with handle = 0x88B7F318
E/LocSvc_utils_ll(856): D/linked_list_remove: Removing from list
E/LocSvc_utils_q(856): D/msg_q_rcv: Received message 0x88B7F318 rv = 0
E/LocSvc_MsgTask(856): D/MsgTask::loop() 866 listening ...
E/LocSvc_utils_q(856): D/msg_q_rcv: Waiting on message
E/LocSvc_ApiV02(856): D/void LocApiV02::reportPosition(const qmiLocEventPositionReportIndMsgT_v02*):2004]: Ignoring position report with sess status = 7, fix id = 119
E/LocSvc_ApiV02(856): I/<--- void globalEventCb(locClientHandleType, uint32_t, locClientEventIndUnionType, void*) line 90 QMI_LOC_EVENT_POSITION_REPORT_IND_V02


Have you tried downloading gps test from playstore and clear your ephemeris data. Then reboot
30th April 2014, 09:01 AM   |  #3  
effry's Avatar
OP Senior Member
Flag Naples
Thanks Meter: 58
 
284 posts
Join Date:Joined: Mar 2011
More
Quote:
Originally Posted by xdm9mm

Have you tried downloading gps test from playstore and clear your ephemeris data. Then reboot

Yes but no help at all the app did not even see see satellites

Inviato dal mio SM-N9005 utilizzando Tapatalk
30th April 2014, 09:05 AM   |  #4  
Member
Thanks Meter: 6
 
45 posts
Join Date:Joined: Apr 2012
My gps doesn't work on Samsung 4.4.2. It works on Temaseks AOSP rom

Sent from my SM-N9005 using Tapatalk
30th April 2014, 09:12 AM   |  #5  
gee2012's Avatar
Recognized Contributor
Flag Heerlen
Thanks Meter: 3,288
 
8,931 posts
Join Date:Joined: Jul 2010
More
Quote:
Originally Posted by effry

Yes but no help at all the app did not even see see satellites

Inviato dal mio SM-N9005 utilizzando Tapatalk

I have a satlock within 3 seconds, may i suggest to reflash the rom you have followed by a data factory reset Runing ND3 stock.
Attached Thumbnails
Click image for larger version

Name:	2014-04-30-09-07-37[1].jpg
Views:	89
Size:	174.3 KB
ID:	2717138  
Last edited by gee2012; 30th April 2014 at 09:14 AM.
30th April 2014, 10:08 AM   |  #6  
Member
Thanks Meter: 6
 
45 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by gee2012

I have a satlock within 3 seconds, may i suggest to reflash the rom you have followed by a data factory reset Runing ND3 stock.

I've tried completely wiping my device and installing several different stock Kitkat roms but it still won't work. Have you ever had any gps problems or has it always worked?

Sent from my SM-N9005 using Tapatalk
30th April 2014, 10:11 AM   |  #7  
gee2012's Avatar
Recognized Contributor
Flag Heerlen
Thanks Meter: 3,288
 
8,931 posts
Join Date:Joined: Jul 2010
More
Quote:
Originally Posted by matust

I've tried completely wiping my device and installing several different stock Kitkat roms but it still won't work. Have you ever had any gps problems or has it always worked?

Sent from my SM-N9005 using Tapatalk

It always worked for me, maybe you just have a defective device (gps module) that needs to be repaired.
30th April 2014, 10:14 AM   |  #8  
Member
Thanks Meter: 6
 
45 posts
Join Date:Joined: Apr 2012
It worked fine for me on 4.3, and works fine on AOSP 4.4.2. Kitkat hasn't been released on any of the carriers in my country so I can only hope that will fix it.

Sent from my SM-N9005 using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes