Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Kitkat (Hammerhead AOSP) compilation errors

OP tthtlc

30th April 2014, 05:01 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: May 2010
Got the following errors after compilation Hammerhead AOSP with "make otapackaage -j4":

target Java: core (out/target/common/obj/JAVA_LIBRARIES/core_intermediates/classes)
javac: target release 1.5 conflicts with default source release 1.7
make: *** [out/host/common/obj/JAVA_LIBRARIES/dumpkey_intermediates/javalib.jar] Error 41
make: *** Waiting for unfinished jobs....
javac: target release 1.5 conflicts with default source release 1.7
make: *** [out/target/common/obj/JAVA_LIBRARIES/core_intermediates/classes-full-debug.jar] Error 41


Full errors are here:

http://pastebin.com/QAFQWbF5

Can someone please help with the error?
30th April 2014, 05:28 PM   |  #2  
shimp208's Avatar
Recognized Contributor
Flag Boston
Thanks Meter: 1,691
 
2,321 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by tthtlc

Got the following errors after compilation Hammerhead AOSP with "make otapackaage -j4":

target Java: core (out/target/common/obj/JAVA_LIBRARIES/core_intermediates/classes)
javac: target release 1.5 conflicts with default source release 1.7
make: *** [out/host/common/obj/JAVA_LIBRARIES/dumpkey_intermediates/javalib.jar] Error 41
make: *** Waiting for unfinished jobs....
javac: target release 1.5 conflicts with default source release 1.7
make: *** [out/target/common/obj/JAVA_LIBRARIES/core_intermediates/classes-full-debug.jar] Error 41


Full errors are here:

http://pastebin.com/QAFQWbF5

Can someone please help with the error?

It's an error relating to the version of Java you have installed on your system. Which version do you have installed? Which Linux distribution/version are you using to compile? If you can tell me these things I can try and help you solve your error.
30th April 2014, 05:53 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: May 2010
Quote:
Originally Posted by shimp208

It's an error relating to the version of Java you have installed on your system. Which version do you have installed? Which Linux distribution/version are you using to compile? If you can tell me these things I can try and help you solve your error.


My java version is the latest 1.7 (from Ubuntu repository):

Ubuntu 12.04.03, LTS, 64-bit

java version "1.7.0_51"
OpenJDK Runtime Environment (IcedTea 2.4.4) (7u51-2.4.4-0ubuntu0.12.04.2)
OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)

javac 1.7.0_51

As per this:

http://forum.pcsoft.fr/fr-FR/pcsoft....licts/read.awp

and this:

https://groups.google.com/forum/#!to...rm/NHhin464dxc

It seemed that Java 7 cannot generate compatible Java 5 binaries, whereas Java 6 still can.

Ok, I shall try downgrading it to Java 6 than.

Am I right to say this?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes