Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[q] powered usb hub not working mad catz m.o.j.o?

OP PHYSC-1

25th April 2014, 12:29 AM   |  #1  
OP Member
Thanks Meter: 21
 
84 posts
Join Date:Joined: Aug 2013
Hi new here,i have the mad catz m.o.j.o and i am trying a brand new and working powered usb hub.But after it initialy detected it 1st time it now refuses to work with the m.o.j.o and on occasion it does but it then pretty quickly stops working again,any ideas what is causing it guys?

The usb debugging isn't causing it either as have disabled and enabled again as it is behaving the same either way,it's a simple generic ebay 7 port powered usb hub. All i would be happy with is getting the keyboard and mouse and my usb sd card reader working all from the hub.

Any help would be greatfully appreciated,and thanks in advance
25th April 2014, 09:42 AM   |  #2  
gwaldo's Avatar
Senior Member
Flag Melb.
Thanks Meter: 29
 
323 posts
Join Date:Joined: Dec 2013
More
Quote:
Originally Posted by OUYA MODDER

Hi new here,i have the mad catz m.o.j.o and i am trying a brand new and working powered usb hub.But after it initialy detected it 1st time it now refuses to work with the m.o.j.o and on occasion it does but it then pretty quickly stops working again,any ideas what is causing it guys?

The usb debugging isn't causing it either as have disabled and enabled again as it is behaving the same either way,it's a simple generic ebay 7 port powered usb hub. All i would be happy with is getting the keyboard and mouse and my usb sd card reader working all from the hub.

Any help would be greatfully appreciated,and thanks in advance

Strange, try removing the power? it could be a power usb issue?
I have a USB keyboard and mouse on a 4 unpowered hub and works fine.
Try the trail and error approach, and one item at a time and test each until you fine what makes it fail.
Good luck.

Edit: the MOJO forum is here BTW:
http://forum.xda-developers.com/mad-catz-mojo
More MOJO users there.
30th April 2014, 06:46 PM   |  #3  
OP Member
Thanks Meter: 21
 
84 posts
Join Date:Joined: Aug 2013
Smile Thanks: POWERED USB HUB NOT WORKING ON MAD CATZ M.O.J.O (SOLVED)
Quote:
Originally Posted by gwaldo

Strange, try removing the power? it could be a power usb issue?
I have a USB keyboard and mouse on a 4 unpowered hub and works fine.
Try the trail and error approach, and one item at a time and test each until you fine what makes it fail.
Good luck.

Edit: the MOJO forum is here BTW:
http://forum.xda-developers.com/mad-catz-mojo
More MOJO users there.

Thanks,i finally got to the bottom of it all,basically added a male to female usb cable a short length like what comes with certain pc external dvd's etc,i have found that if quihoo 360 security app is set to sleep or if i reboot the m.o.j.o then i loose keyboard and mouse through the usb to ps2 adaptor and extension cable atachtched to the powered usb hub.

So now on waking up or restarting the console i simply disconnect the ps2 to usb from the usb extension cable attached to the hub and then detach the hub from the male to female atached to the console.

All i do at that stage then is reatach the hub to the usb male to female attached to the console,then just attach the ps2 to usb to the usb extension cable still attached to the hub and voila all working again.

Hope this helps anyone else who finds the keyboard drops on their mad catz m.o.j.o using a powered hub or ps2 to usb adaptor or both etc
Last edited by PHYSC-1; 30th April 2014 at 06:50 PM. Reason: spelling and additions
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes