Post Reply

[Q] Need help!! File Permissions

OP gamer999

2nd May 2014, 05:52 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: May 2014
Hi all,

I am new here and here goes my first post/querstion at XDA.
I was using some apk when my Device suddenly crashed. I restarted, everything looked fine. The problem started when I tried to open other apk which needs data file from Android Data folder for second operation. The apk was not able to access the files from data folder. I checked my file explorer and found the permissions(displayed at the end of the folder) have changed to -drw(for sure) from -rw(most probably). With this I am not able to delete/move any file from the device storage because the permissions of all other folders have changed to as abaove. If I try to move file, it makes a new copy on my extStorage but the original file is there as it is. The files can't be deleted either. Since my tab is rooted, I installed Root explorer to change file permissions. The permissions under Owner are all unchecked and Group/Others are checked. When I check the Read/Write/Execute permissions for owner, it says cannot be modified(its default disability message). Fed up of all this I went for Factory reset as a final option. I tried to backup using Ti but after some 10% it said not enough space. So I manually backed up whatever I could and went ahead with reset. I successfully did the factory reset and my tablet looked as fresh as when I bought it the first time. All factory apps only but when I was about to be happy, I opened the device storage just to find all those files and data still there, staring at me with their -drw stamp.
My device is Iberry(China I guess) and works on ICS. It is rooted. I had Su Superuser and busy box installed prior to the factory reset but after Factory Reset all apps are gone except their data in the device storage. Please help!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Questions and Answers by ThreadRank