Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,741 Members 46,943 Now Online
XDA Developers Android and Mobile Development Forum

[Q] (Q) Water damage Moto G

Tip us?
 
TheGerben
Old
(Last edited by TheGerben; 20th February 2014 at 01:28 PM.)
#11  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2012
I also think that. But that G that in the water was for 30 minutes survived. But guys, don't buy him with the intention that he's almost water proof. I did that

I think I'll contact the customer support, and maybe they say to just buy a new one, and that they will refund the old one. If that works I'm happy.

I can't send the link, the're afraid of spam. That sucks.
 
rudasna
Old
#12  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Mar 2014
TheGerben, did you manage to solve your problem? I did the same... I drop my phone into water for like 5 sec, two days ago... and now I can't switch it on... not sure what to do...
 
Househeadrory
Old
#13  
Junior Member
Thanks Meter 1
Posts: 4
Join Date: May 2014
Location: Wakefield
I think I've just killed my Moto G!!

I accidental put it in the washer whilst it was in the pocket of a pair of jeans , stopped the washing machine before it ever went on any fast cycles and pulled the Moto G out to find it still alive.

The battery showed near flat from what previously would have been a 3/4 full battery, and a red line was shown over a picture of a sim card on the display also.
I powered down the phone and took the back off where the phone was sodden inside the back over the battery etc and gave it a wipe down and stuck the phone over the exhaust of my dehumidifier.


Now when I've gone to turn the Moto G back on it won't fire backup into life, and when I plug the charger in the white led blinks as though it's charging.
 
ManBearrrPig
Old
#14  
ManBearrrPig's Avatar
Senior Member
Thanks Meter 32
Posts: 232
Join Date: Jan 2012
Quote:
Originally Posted by Househeadrory View Post
I think I've just killed my Moto G!!

I accidental put it in the washer whilst it was in the pocket of a pair of jeans , stopped the washing machine before it ever went on any fast cycles and pulled the Moto G out to find it still alive.

The battery showed near flat from what previously would have been a 3/4 full battery, and a red line was shown over a picture of a sim card on the display also.
I powered down the phone and took the back off where the phone was sodden inside the back over the battery etc and gave it a wipe down and stuck the phone over the exhaust of my dehumidifier.


Now when I've gone to turn the Moto G back on it won't fire backup into life, and when I plug the charger in the white led blinks as though it's charging.
if you are 100% sure it is completely dry (if not put it in a bag filled with rice for a day or two), try the following:

-plug it in the charger
-hold power button 2-3min
-leave it charging for an hour
-unplug it
-hold power button for 30seconds
-it should boot
 
Househeadrory
Old
#15  
Junior Member
Thanks Meter 1
Posts: 4
Join Date: May 2014
Location: Wakefield
Quote:
Originally Posted by ManBearrrPig View Post
if you are 100% sure it is completely dry (if not put it in a bag filled with rice for a day or two), try the following:

-plug it in the charger
-hold power button 2-3min
-leave it charging for an hour
-unplug it
-hold power button for 30seconds
-it should boot
I dried the most of the water out using the dehumidifier, but now as I type this reply the Moto G is sealed in a tupa ware tub with a moisture bag where it's going to be left till tomorrow night before going back on charge.
 
Househeadrory
Old
#16  
Junior Member
Thanks Meter 1
Posts: 4
Join Date: May 2014
Location: Wakefield
Ok, so it's less than 25 hours away since I gave my Motorola Moto G a little wash in my washer at around 7pm last night, I dried the phone mostly by towel and placed it on the exhaust of my dehumidifier for an hour.
Next the Moto G was placed minus back cover and sim card in an air tight Tupperware tub with a bag of absorbent crystals where it stayed there until 10am this morning.

When I took the Moto G out of the tub, I put it on charge and held the power button as suggested on this thread for around 3 minutes when the phone was put first on charge.
Whilst doing this the Moto G's white led light would blink every so often.

The Moto G must have only been on charge barely 15 minutes before it sprang back into life by itself buzzing and bleeping away with notifications as I'd left it WiFi enabled.

So yes my Moto G is back very much alive!!
First test indicates both front and back cameras work fine with no mist, all my settings, apps and messages are still as they were.
The phone now has the sim card placed back in which works fine, the rest of the phone appears to be 100% working although as I type this, I have still yet to make a phone call with it!
The Following User Says Thank You to Househeadrory For This Useful Post: [ Click to Expand ]
 
Househeadrory
Old
#17  
Junior Member
Thanks Meter 1
Posts: 4
Join Date: May 2014
Location: Wakefield
Update

Within an hour of the Moto G working again I noticed the sim card fault symbol where the signal band indicator should be, I then powered down the phone and tried to boot it up agin.
.It was dead!!
I took the back off and ragged out the sim card which had moisture on it, this meaans that I hadn't managed to get r'id of all the water inside the Moto G!!

I nipped out to the pound shops for a precision screwdriver set to take the Moto G apart.
Whilst out at the shops I contemplated getting a new sim free Moto G at 159.99 from Argos, but saw "this item is excluded from our 30 day money back guarantee" noted so I turned away without one.
This because if I could get my Moto G working perfectly again, it would be pointless and would have a struggle returning the new Moto G back to Argos if I didn't need it.

Anyway, I returned home and got busy taking the inner back casing off my Moto G to be greeted by globules of water inside.
I wiped off the excess water with kitchen towel and I have place the phone back on the exhaust of my dehumidifier for 30 minutes.

I will post back with updates once I' think the phone has dried out enough to try putting back together and placing it back on charge etc.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes