Default 4.4.2 flashing 4.3 ROMs

I thought i'd ask just to be safe than sorry later on, but is it possible to flash 4.3 ROMs through Safestrap if I upgraded to NC5 or do I have to downgrade first?