Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,064 Members 41,011 Now Online
XDA Developers Android and Mobile Development Forum

Just bought Galaxy S5 Gold but can't get it work properly

Tip us?
 
PeritoX
Old
#1  
Senior Member - OP
Thanks Meter 3
Posts: 111
Join Date: Feb 2012
Unhappy Just bought Galaxy S5 Gold but can't get it work properly

I was running on a Nexus 4 and I just bought a Galaxy S 5 Gold and I'm so excited. Unfortunately, I'm having two major problems.

1- update could not be downloaded due to an error 920 [when updating the existing apps on phone like Dropbox or Chrome!]
2- Sync is currently experiencing problems. It will be back shortly. [For my gmail account that has my contacts/calendar/drive/keep]

I've searched all over the web and tried everything. I tried:
1- Turn off Wifi, Turn on Wifi
2- Clear Cache - Clear data from Google Play Store app
3- Reboot
4- Reset phone (Twice!) and try again.

and nothing is working. I noticed that if I turn of the WiFi and try to update using the 3G connection, it works properly. The error only appears when I'm connected to WiFi. Keep in mind that I can browse and use the internet normally so the phone is indeed connected to the internet when connected to WiFi.

I'm literally close to tears. Any kind of help will be appreciated !!
 
dedalmapeti
Old
#2  
Member
Thanks Meter 2
Posts: 32
Join Date: Aug 2011
Location: Bucharest
Try to clean cache, then remove Google account, re-enable Google account and this should do it. Worked for me.

Sent from my SM-G900F using XDA Premium 4 mobile app
 
dynospectrum
Old
(Last edited by dynospectrum; 5th May 2014 at 09:52 PM.)
#3  
dynospectrum's Avatar
Senior Member
Thanks Meter 348
Posts: 721
Join Date: Jan 2012
Location: Chicago, IL
Quote:
Originally Posted by PeritoX View Post
1- update could not be downloaded due to an error 920 [when updating the existing apps on phone like Dropbox or Chrome!]
[INFO] Google play errors Explained (with fixes) [Update 1-5-2014]
http://forum.xda-developers.com/show...php?p=52230369

From thread
error 920:

app could not be downloaded.

Solution:

Method 1:

Turn your wi-fi off
turn your wi-fi on
run google play store and install or update the app

method 2:

Go to settings>>accounts>> delete your google account synced with google play.
Restart phone and add your google account back in the settings. Alternately, add a different google account.
Run google play store and download your app.

Method 3:

Go to settings >> apps >> open “all” tab
find and click google play store >>clear cache and clear data
now from the same tab uninstall google play store updates
restart your phone, open google play store and install the app
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes