Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,879 Members 49,967 Now Online
XDA Developers Android and Mobile Development Forum

Cannot Mount System As R/W, HELP!

Tip us?
 
FreakyFreakGA
Old
#1  
Senior Member - OP
Thanks Meter 22
Posts: 207
Join Date: Sep 2012
Default Cannot Mount System As R/W, HELP!

Okay, I am having the weirdest of issues, on my Nexus 7 2013 both when it was running stock android 4.4.2 and now CM11, I cannot get my system to mount as R/W. Here's what I mean.

When I use Root Explorer, I can "mount" the system and it will say mounted as R/W, but ANY time it says the system is mounted as R/W and I do anything on the device that would require the system to be R/W like writing to /System folder, EVEN if Root explorer says its mounted as R/W as soon as I move a file to /System it will say something like "File system is not mounted as R/W, Mount as R/W?" which at this point it will go into R/W mode, but as soon as it's done the /System automatically seems to go back to R/O and I always have to reconfirm when I move a file to remount.

This is not such a big issue EXCEPT when I want to do ANYTHING in adb, anything I try in adb that requires that the system be in R/W will not work even in Root Explorer says the system is mounted as R/W, any time I try pushing files to /System or even trying to make a logcat the adb always comes back with "Not Allowed System Is Read Only"

My device is unlocked, rooted and has a custom recovery, and was running stock kernel with stock Android 4.4.2, but now i'm running CM11 with their kernel, I used Skipsoft Unified Toolkit for everything.
 
LinearEquation
Old
#2  
LinearEquation's Avatar
Senior Member
Thanks Meter 403
Posts: 1,687
Join Date: Aug 2013
Location: Midwest

 
DONATE TO ME
Quote:
Originally Posted by FreakyFreakGA View Post
Okay, I am having the weirdest of issues, on my Nexus 7 2013 both when it was running stock android 4.4.2 and now CM11, I cannot get my system to mount as R/W. Here's what I mean.

When I use Root Explorer, I can "mount" the system and it will say mounted as R/W, but ANY time it says the system is mounted as R/W and I do anything on the device that would require the system to be R/W like writing to /System folder, EVEN if Root explorer says its mounted as R/W as soon as I move a file to /System it will say something like "File system is not mounted as R/W, Mount as R/W?" which at this point it will go into R/W mode, but as soon as it's done the /System automatically seems to go back to R/O and I always have to reconfirm when I move a file to remount.

This is not such a big issue EXCEPT when I want to do ANYTHING in adb, anything I try in adb that requires that the system be in R/W will not work even in Root Explorer says the system is mounted as R/W, any time I try pushing files to /System or even trying to make a logcat the adb always comes back with "Not Allowed System Is Read Only"

My device is unlocked, rooted and has a custom recovery, and was running stock kernel with stock Android 4.4.2, but now i'm running CM11 with their kernel, I used Skipsoft Unified Toolkit for everything.
Try ES File Explorer. Make sure you have it set to r/w also turn the root explorer on in the tools section of ES File Explorer.

Sent from my Nexus 7 Flo running CM 11 4.4.2 with ElementalX Kernel using XDA Premium 4 mobile app
[ROOT] 2013 KFHD7 Soho firmware 11.x.x.x (no camera)
http://forum.xda-developers.com/show...44736&page=101 If needed contact @GranPC for an updated Firerooter.
[Root] 2012 KFHD7 Tate http://forum.xda-developers.com/show....php?t=1886460
2nd [Bootloader]/[TWRP] KFHD7 Tate
http://forum.xda-developers.com/show....php?t=2128848
http://forum.xda-developers.com/show....php?t=2271909
KFHD7 Tate System Restore Tool http://forum.xda-developers.com/show....php?t=1951254
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes