Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,770,637 Members 39,878 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Touch inop after repair

Tip us?
 
bighairyg
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: May 2014
Default [Q] Touch inop after repair

Ok, so here's the deal:

My nephew has an HTC Evo 4g LTE and just out of the blue gave him a 'system error', powered down, and would not restart. After talking directly with HTC and a local repair shop, we determined that it had a bad motherboard.

I then purchased a used phone off of Ebay as a donor for the motherboard (the original phone is in pristine condition, and I wanted to keep it that way). The donor phone has a shattered glass, but is fully functional. Please keep in mind that both of these are stock, never rooted or unlocked, and were never opened up before (black sticker was still in place over motherboard cover screw on both units).

Today I did the transplant. I have what I believe to be above average technical and mechanical skills. The process of disassembling and reassembling the phones was done very cautiously and meticulously.

Here's where the problem comes in. Upon rebooting the original phone with the transplant motherboard, the touch no longer works. I removed and replaced the motherboard 3 more times, each time making sure everything was properly plugged in and locked down, but I still have the same results. I did do a factory reset and a recovery through the bootloader menu.

I figured that someone here must know what is going on. The original phone worked perfectly before the 'system error', and again, the donor phone worked perfectly minus the shattered screen. Does anyone have some insight on what might be the problem? I would hate to have to purchase a new phone unless absolutely necessary. Like I said earlier, this is my nephew's phone, and he does not currently have a job, so any fix would require me to pay for it...
 
AarSyl
Old
#2  
AarSyl's Avatar
Senior Member
Thanks Meter 723
Posts: 1,794
Join Date: Aug 2012
Location: NJ
I'm not going to try to go into much detail on a subject that I don't know about, but you might want to look into troubleshooting and researching to see if your digitizer has been ruined in your transplant. From what I understand, it is a pretty common occurrence in some users' DIY endeavors.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes