Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Linux

OP Dankchild

7th May 2014, 04:41 AM   |  #1  
Dankchild's Avatar
OP Senior Member
Flag Baton Rouge, LA
Thanks Meter: 111
 
192 posts
Join Date:Joined: Nov 2008
Donate to Me
More
Is it possible to dual boot kit Kat and android? Does our device support linux?

Sent from my SM-N900A using Tapatalk
7th May 2014, 06:59 AM   |  #2  
Member
Thanks Meter: 8
 
46 posts
Join Date:Joined: Sep 2011
More
kitkat is android 4.4. the latest firmware is 4.4.2. android is a variant of linux.

dual boot kitkat and linux - i'm not sure.

linux in parallel - https://play.google.com/store/apps/d...linuxonandroid
7th May 2014, 09:35 AM   |  #3  
Member
Thanks Meter: 2
 
33 posts
Join Date:Joined: Aug 2013
There are projects to install linux on android in various ways or to install software similar to linux desktops.

In principle, they should work on our device. But, I have tried a few, with no luck. I guess it is
because the Samsung firmware is modified. It seems to be a question of permissions.

I tried debian kit http://forum.xda-developers.com/show....php?t=2737935. I have
made a bit of progress since then, but it still does not work.

I tried both botbrew and botbrew basil. Neither of these worked. Always 'permission denied'.
As I said in the thread above, sometimes 'shell' can do things that 'root' cannot. Someone with
a different Samsung device was unable to install debian kit, but could do it after flashing cyanogenmod.
I want to retain S pen capabilities, so I don't want to do this. But if all these problems are really
due to the Samsung ROM....

There are some methods that don't require root. I have not tried these yet. You can look on the play store.
One difference is if you install linux in a chroot environment, or if it has access to the android files.
debian kit requires root and is not dual boot and not chroot. The
linux software is visible along with android binaries while debian kit is switched on.

I am also looking for flexible ways to transfer files over USB. No luck yet. E.g. I want to maintain a mirror of
a directory from a linux desktop to the device. Wifi is slower and not always available. There is an
app Ftp Server that allows you to ftp over USB using port forwarding with adb. Together with lftp,
this should provide a solution. But, this also fails for me. I can't be sure it is a Samsung problem.

I'd like to see an explanation of the relevant differences between Samsung and plain android.
7th May 2014, 07:57 PM   |  #4  
Member
Thanks Meter: 2
 
33 posts
Join Date:Joined: Aug 2013
See these threads on installing linux on Note 10.1 2014

http://forum.xda-developers.com/show....php?t=2590311

http://forum.xda-developers.com/show....php?t=2587915

http://forum.xda-developers.com/show....php?t=2737935
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes