FORUMS

Earthquake Early Warning in Your Pocket

Probably all of us reading this have a smartphone in our pocket. For many of us, the … more

Sony: The OEM You Want To Save

In our recent Discuss article, we asked you readers on which OEM you would like to help. While the … more

How to Lock and Protect Your Apps – XDA Xposed Tuesday

The smartphone revolution has passed. Everybody has mobile apps. Some of … more

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Broken Xperia Play

282 posts
Thanks Meter: 50
 
By mhnx, Senior Member on 29th April 2014, 05:43 PM
Post Reply Subscribe to Thread Email Thread
Hello, one month ago my Xperia Play dropped down on floor and my digitizer broke, I didn't have problems with the touch. I was planning to replace the screen but after a reboot my screen gone wild.

I press the power button to power-on the device and after some seconds I get this screen. In 1~ minute the screen goes off and if I press the wake button this image comes back up, something like it booted and it asks the pin. That means my phone is working and the lcd is dead?
Thanks in advance.

Click image for larger version

Name:	uploadfromtaptalk1398789438743.jpg
Views:	68
Size:	123.4 KB
ID:	2715883

Sent from my Evo3D
Last edited by mhnx; 29th April 2014 at 07:57 PM.
 
 
29th April 2014, 09:51 PM |#2  
Bakisha's Avatar
Senior Member
Thanks Meter: 512
 
More
It show colors, so i don't think it's broken lcd. It could be damaged lcd flex cable or slider flex cable. Try to open/close slider multiple times and see are there any changes on the screen.
The Following 2 Users Say Thank You to Bakisha For This Useful Post: [ View ]
29th April 2014, 10:26 PM |#3  
mhnx's Avatar
OP Senior Member
Flag Thessaloniki
Thanks Meter: 50
 
Donate to Me
More
Quote:
Originally Posted by Bakisha

It show colors, so i don't think it's broken lcd. It could be damaged lcd flex cable or slider flex cable. Try to open/close slider multiple times and see are there any changes on the screen.

I will test tomorrow night when I get home. Thanks for the suggestion.

Sent from my Evo3D
30th April 2014, 11:16 AM |#4  
rexodor's Avatar
Junior Member
Thanks Meter: 1
 
More
Info 2
Quote:
Originally Posted by Bakisha

It show colors, so i don't think it's broken lcd. It could be damaged lcd flex cable or slider flex cable. Try to open/close slider multiple times and see are there any changes on the screen.

In my case it worked, I changed "slider flex cable" and all OK.
But the touch screen does not work well in the last imaginary division of the screen below and on the left side.
Thank you.
The Following User Says Thank You to rexodor For This Useful Post: [ View ]
3rd May 2014, 08:03 PM |#5  
mhnx's Avatar
OP Senior Member
Flag Thessaloniki
Thanks Meter: 50
 
Donate to Me
More
It works, the screen will be replaced in this week. I have to change the flex cable too? Thanks for your help.

Sent from my Evo 3D
7th May 2014, 09:10 PM |#6  
CriGiu's Avatar
Senior Member
Thanks Meter: 550
 
More
Quote:
Originally Posted by mhnx

It works, the screen will be replaced in this week. I have to change the flex cable too? Thanks for your help.

Sent from my Evo 3D

That "fuzzy screen" as they call it is surely caused by the flex cable (I mean the one which connects lcd and other things with MoBo), as it happened to me something like 2 months ago, and I had to replace that cable for the second time.
So you'd better change it, because even if you buy a new screen you won't be able to use it

Inviato dal mio R800i con Tapatalk 2
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes