Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,698 Members 48,744 Now Online
XDA Developers Android and Mobile Development Forum

[Chroot] motsnd (no sound)

Tip us?
 
ferviverus
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 10
Join Date: May 2014
Default [Chroot] motsnd (no sound)

Hello!

I have a little problem

I have a cyanogenmod 10.1 and i'll try to use Linux (without webtop, by chroot)
I have a little problem, because the Linux can't propertly recognize Motsnd driver (probably it doesn't have), but probably Webtop Distro have some hacks (or something like that) to play sound from Atrix

Maybe somebody check it and have solution? I found only:
http://forum.xda-developers.com/show....php?t=2420586

But it isn't good idea (only if you play music or watch movies, because it has 10 sec delay)

Thanks
Fervi

PS. Sorry for my bad english
 
andresrivas
Old
#2  
Senior Member
Thanks Meter 343
Posts: 1,004
Join Date: Aug 2010
Location: Córdoba
Have you tried this?
http://www.hunterdavis.com/2012/05/2...ux-on-android/

Enviado desde mi MB860 usando Tapatalk 2
Motorola Personal 501 -> Motorola StarTac -> Motorola v360 (1gb sd, iTunes, native, non-java apps) -> Motorola Rokr E2 (SDHC 8Gb, native apps, O.C., My own custom Rom, AWESOME PHONE) -> Motorola C115 (Custom Ringtones xD ) -> Motorola Milestone (A.K.A Droid) (Froyo, rooted, stolen :'( ) -> Motorola Atrix 4G (Blur ICS)


Yup. I've been a Motofan all my life so far...
 
ferviverus
Old
#3  
Junior Member - OP
Thanks Meter 2
Posts: 10
Join Date: May 2014
Technically, your problem is how to create a Linux chroot in Android

There is no info about sound

I'll try to copy alsa driver from Webtop to Chroot, but it doesn't work (drivers have EABI4, but Debian have EABI5 [architecture?])

Fervi
 
ferviverus
Old
#4  
Junior Member - OP
Thanks Meter 2
Posts: 10
Join Date: May 2014
Well, it doesn't look like a architecture conflict, because i can run (by chroot) GenTop, so EABI4 is supported

But the sound still doesn't work

Quote:
ALSA lib dlmisc.c:252snd1_dlobj_cache_get) Cannot open shared library /usr/lib/arm-linux-gnueabihf/alsa-lib/libasound_module_ctl_moto.so
But the file is there

Maybe somebody have idea about fix this problem?

Fervi
 
andresrivas
Old
#5  
Senior Member
Thanks Meter 343
Posts: 1,004
Join Date: Aug 2010
Location: Córdoba
Check the file's permissions. Also, check that it isn't a soft link to nowhere

Enviado desde mi MB860 usando Tapatalk 2
Motorola Personal 501 -> Motorola StarTac -> Motorola v360 (1gb sd, iTunes, native, non-java apps) -> Motorola Rokr E2 (SDHC 8Gb, native apps, O.C., My own custom Rom, AWESOME PHONE) -> Motorola C115 (Custom Ringtones xD ) -> Motorola Milestone (A.K.A Droid) (Froyo, rooted, stolen :'( ) -> Motorola Atrix 4G (Blur ICS)


Yup. I've been a Motofan all my life so far...
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes