Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Can somone help with droid bionic/straight talk?

OP Cap'n Jazz

12th April 2014, 08:16 AM   |  #1  
OP Member
Thanks Meter: 9
 
59 posts
Join Date:Joined: Jan 2013
I'm trying to get this bionic to work with my straight talk sim. Could anybody help?
9th May 2014, 09:24 AM   |  #2  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Nov 2013
Thumbs up Droid Bionic on Straight Talk
The way I did mine is after I used RadioComm v11.12.2 I used RSD Lite to flash back to Stock ROM and not it reads the Straight Talk SIM Cards I had to do it twice but in the settings it still says unknown network but it works fine I am running T-MO on Straight Talk line.

I had to do this twice:
First... make sure you have Moto drivers 5.4.0 (or newer)
installed on your PC. Install RadioComm (I used 11.12.2).
The first time you do this and use Radiocomm, you will be
prompted for other drivers to install, let them.
Boot Bionic, connect USB cable, put in PC MODE
Start RadioComm
select Main -> MA -> Common -> MDM 6x00 chipset base
select settings -> USB -> USB PST Driver
select the FTM Common1 tab
Try the buttons at top to read Version and MEID, if response
is GREEN, you can proceed. If RED, there is likely a driver
error that you need to resolve. (If drivers are correct,
you should see moto usb networking listed under NETWORK
Adapters in Windows Device Manager). Possible ways to fix
driver issue...
1. re-install Moto 5.4.0 drivers and reboot PC.
2. reboot phone (remove/replace battery if possible).
3. when connecting phone to PC, ensure its connected in PC MODE, not USB Mass Storage, Charge Only or other...
in the NVAccess drop down, select 1877 click read.
should show 07000000000000000.... change the first characters to... 8703E80400000200
click write
exit radiocomm
disconnect phone
power phone off, insert Non-VZW SIM, and power up.
Last edited by knightvamp; 9th May 2014 at 10:47 PM. Reason: added steps
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes