Post Reply

/etc/system/snd_soc_msm/snd_soc_msm_2x_fusion3 from Stock ROM

OP nostupidthing

3rd May 2014, 04:01 PM   |  #11  
OP Senior Member
Thanks Meter: 137
 
452 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by il2stormo

I had the same 2nd Mic problem with my ZR. It came with the 10.3.1.a.2.67 firmware out of the box. I went ape trying to find a solution since January. Luckily i found a post from user "nigoc" in Sonymobile forums who said downgrading the phone to 10.1.1.A.1.310 (JellyBean 4.1.2) solves the problem. I did it, and heck he was right. My camera now works as expected. All those "streaming-like" sounds in my video recordings are gone and the sound quality is very good.

I'm attaching the /etc/system/snd_soc_msm/snd_soc_msm_2x_fusion3 file from my phone. Hope it works in 4.2.2

am not having "stream" noise in video recording... but low volume... think it's mainly 2nd mic, which in turn affect noise cancellation functionality.

i guess maybe cm/fxp devs used yuga (xperia z) config on zr, and that's causing a problem???

anyway, too tried to try now, later... later...
9th May 2014, 01:49 PM   |  #12  
OP Senior Member
Thanks Meter: 137
 
452 posts
Join Date:Joined: Nov 2012
with soundfix (http://forum.xda-developers.com/show...php?p=52514028)
Attached Files
File Type: zip snd_soc_msm_DoO37_v3.zip - [Click for QR Code] (390.6 KB, 41 views)
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes