Unhappy [Q] gapp

hello
i've recently rooted my dell streak 7 to jellybean 4.2.2.but after installing it when i was trying to install gapps throughTWRP it wasnot allowing me to do so.the error message was ERROR FLASHING ZIP.i tried to download many versions of gapps but couldnt succed.so please anybody help me out.without play store i cant download any app also.