Open War for Open Android: Antitrust for Cyanogen?

Android and openness is something we talk about all the time, but the recent … more

What Do You Do with All of Your Old Photos?

Smartphone cameras have advanced so tremendously over the past few years that they have … more

Diving into the April 2015 Material Design Update

Before the release of Android 5.0 Lollipop, the Holo Design guidelines served as the … more

New Cyanogen Partnerships Bring Privacy Concerns

New Privacy concerns have emerged regarding Cyanogen’s latest announcements, … more
Post Reply Subscribe to Thread Email Thread

[Q] Google search not searching my device

10th May 2014, 09:38 PM |#1  
OP Junior Member
Thanks Meter: 1
 
24 posts
Join Date:Joined: May 2014
After rooted the phone and using this rom - v2.0 XZ2 AROMA, google search doesn't not index my device (contacts/ apps). Which makes it unable to search my device. I can't find any settings in the google search app or google settings regarding to this. How should I fix this?
 
 
10th May 2014, 09:51 PM |#2  
nintendolinky's Avatar
Senior Member
Flag Wakefield, West Yorkshire
Thanks Meter: 280
 
1,238 posts
Join Date:Joined: May 2009
Donate to Me
More
Delete the preinstalled play services, with a root explorer app, reboot and reinstall from the play store, it will now work.

Sent from my D6503 using Tapatalk
The Following User Says Thank You to nintendolinky For This Useful Post: [ View ]
10th May 2014, 10:02 PM |#3  
OP Junior Member
Thanks Meter: 1
 
24 posts
Join Date:Joined: May 2014
@nintendolinky, how should I do this "Delete the preinstalled play services, with a root explorer app"? Should I be looking for a folder? or a bunch of files?
10th May 2014, 10:05 PM |#4  
nintendolinky's Avatar
Senior Member
Flag Wakefield, West Yorkshire
Thanks Meter: 280
 
1,238 posts
Join Date:Joined: May 2009
Donate to Me
More
In priv-app there is gmscore.apk, delete that, reboot and then reinstall play services from the play store.

Sent from my D6503 using Tapatalk
Last edited by nintendolinky; 10th May 2014 at 10:11 PM.
The Following User Says Thank You to nintendolinky For This Useful Post: [ View ]
10th May 2014, 10:22 PM |#5  
OP Junior Member
Thanks Meter: 1
 
24 posts
Join Date:Joined: May 2014
I am using "Root Browser". Trying to uninstall "system/priv-app/GmsCore.apk" got "Uninstall unsuccessful". What could be wrong?
10th May 2014, 11:22 PM |#6  
aarongillion63's Avatar
Senior Member
Flag Grand Rapids MI
Thanks Meter: 110
 
234 posts
Join Date:Joined: Apr 2014
Donate to Me
More
Quote:
Originally Posted by khumash

I am using "Root Browser". Trying to uninstall "system/priv-app/GmsCore.apk" got "Uninstall unsuccessful". What could be wrong?

You need to "delete" the file, not "uninstall" it.

Sent from my SCH-I605 using XDA Free mobile app
The Following User Says Thank You to aarongillion63 For This Useful Post: [ View ]
10th May 2014, 11:27 PM |#7  
OP Junior Member
Thanks Meter: 1
 
24 posts
Join Date:Joined: May 2014
I got it resolved by downloading ES file browser. This time tapping gmscore.apk shows "install" rather than "uninstall". I just "install" the apk and the phone search feature is back to normal now. Thanks everyone for the help.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes