Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Stop Your Screen From Turning Off with KeepItOn

We all know the feeling of reading a news article orrather longdocument, when our screen … more

The XDA LG QPair Developer Challenge Voting Has Begun!

It seems like it was just yesterday that weannounced that we had paired up with LGto … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Wifi refuses to turn on. Ever.

OP Thunder_54

10th May 2014, 09:27 AM   |  #1  
OP Junior Member
Thanks Meter: 4
 
29 posts
Join Date:Joined: Aug 2012
I know, I know. This thread is oh so popular here. Well after searching and trying several different things my wifi STILL will not turn on. This of course first started after I did Samsung's OTA update to 4.3.

Let me make the problem extra clear just for ease. I will tap the wifi to turn it on (Either from the notification hot keys or directly from settings). It will pretend to be doings something for a few seconds, and then goes back to being off. It never shows me hotspots. Never ever connects. Nothing. Just turns back off.

So after dealing with this and crawling at a snail's pace with mobile data on my stock 4.3 Sprint Samsung Galaxy S3 for several months, I decided it was time to root and ROM my phone because that would TOTALLY fix the problem. Well I was wrong.

I have flashed, two ROMs and three kernels:
The people's ROM + its own kernel (I think) (http://forum.xda-developers.com/show....php?t=2013463) -- This didn't work, and I didn't really like the ROM so I looked for another option and found this
Stock 4.3 Rooted + "Wifi fix" kernel Rev 2 (http://forum.xda-developers.com/show....php?t=2541900) -- I thought I had finally found the answer. But no. This too failed.

And then just a few minutes ago I flashed the first version of the "Wifi fix" kernel listed above. This also has had no effect.

So what do I do now? I can't just NOT have wifi. I'm fed up. Sorry if parts of this seem overly sarcastic and dramatic. It's just that I've been putting off even fixing this for so long, and now that i'm taking steps to fix it, nothing is working like it says it will. I just want wifi. That's all. Ugh.

Is there maybe a newer kernel with wifi fix I can flash? A different ROM? Maybe something totally different I don't know about?

I'll be happy to provide any information needed. Thanks in advance.
Last edited by Thunder_54; 10th May 2014 at 09:32 AM.
The Following User Says Thank You to Thunder_54 For This Useful Post: [ View ]
10th May 2014, 01:18 PM   |  #2  
roirraW "edor" ehT's Avatar
Senior Member
Flag Columbus, OH
Thanks Meter: 1,811
 
3,431 posts
Join Date:Joined: May 2010
More
Hi! Sorry to hear about the trouble you're having. Could you tell me in your Settings / More / About Device, what Baseband version you're on?

Have you tried ODINing the original 4.3 tar file after backing up everything you want to keep from the internal "SD" (because it will wipe everything but the external microSD)?

Is it under warranty?

Sent from my Sprint Samsung Galaxy SIII with M.O.A.R. v9.0, dkp kernel dated 3/20/2014 and TWRP v2.7.0.0.
10th May 2014, 08:16 PM   |  #3  
OP Junior Member
Thanks Meter: 4
 
29 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by roirraW "edor" ehT

Hi! Sorry to hear about the trouble you're having. Could you tell me in your Settings / More / About Device, what Baseband version you're on?

Have you tried ODINing the original 4.3 tar file after backing up everything you want to keep from the internal "SD" (because it will wipe everything but the external microSD)?

Is it under warranty?

Sent from my Sprint Samsung Galaxy SIII with M.O.A.R. v9.0, dkp kernel dated 3/20/2014 and TWRP v2.7.0.0.

Thanks for the reply,I really appreciate it

Yeah sure!

Baseband version: L710VPUCMK3

Do you mean have I ODIN'd Samsung's 4.3 update? I have not tried ODINing it. I have thought about reflashing the firmware though (http://www.sammobile.com/firmwares/3/?download=22379), but I was unsure about a few things with that. Mainly if it would unroot me somehow, or if there would be KNOX issues.

It is not under warranty unfortunately :/

Small update: I tried flashing this modem: http://forum.xda-developers.com/show...&postcount=145

Wifi is still broken. Acting the same. :/
Last edited by Thunder_54; 10th May 2014 at 09:07 PM.
The Following User Says Thank You to Thunder_54 For This Useful Post: [ View ]
10th May 2014, 11:07 PM   |  #4  
roirraW "edor" ehT's Avatar
Senior Member
Flag Columbus, OH
Thanks Meter: 1,811
 
3,431 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by Thunder_54

Thanks for the reply,I really appreciate it

Yeah sure!

Baseband version: L710VPUCMK3

You're welcome! If L710VPUCMK3 was the modem you were on before your update from the post you mention below, that was the same modem.

Quote:

Do you mean have I ODIN'd Samsung's 4.3 update? I have not tried ODINing it. I have thought about reflashing the firmware though (http://www.sammobile.com/firmwares/3/?download=22379), but I was unsure about a few things with that. Mainly if it would unroot me somehow, or if there would be KNOX issues.

It is not under warranty unfortunately :/

Yes, that's what I meant. Yes flashing a stock tar would unroot you until you alai ODINed a custom recovery and then flashed SuperSU.zip to re-root.

Since you're out of warranty, you don't have to worry about whether you trip the warranty switch (Knox), which flashing a custom recovery or kernel will do once you ODIN 4.3 or 4 4. I would choose 4.4 if I were you at this point. You can still root it and it's even better than 4.3,which I already loved. Now 4.4 is so good, it's turned my loving 4.3 to having liked it.

Quote:

Small update: I tried flashing this modem: http://forum.xda-developers.com/show...&postcount=145

Wifi is still broken. Acting the same. :/

Sent from my Sprint Samsung Galaxy SIII with M.O.A.R. v9.0, dkp kernel dated 3/20/2014 and TWRP v2.7.0.0.
10th May 2014, 11:23 PM   |  #5  
OP Junior Member
Thanks Meter: 4
 
29 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by roirraW "edor" ehT

You're welcome! If L710VPUCMK3 was the modem you were on before your update from the post you mention below, that was the same modem.



Yes, that's what I meant. Yes flashing a stock tar would unroot you until you alai ODINed a custom recovery and then flashed SuperSU.zip to re-root.

Since you're out of warranty, you don't have to worry about whether you trip the warranty switch (Knox), which flashing a custom recovery or kernel will do once you ODIN 4.3 or 4 4. I would choose 4.4 if I were you at this point. You can still root it and it's even better than 4.3,which I already loved. Now 4.4 is so good, it's turned my loving 4.3 to having liked it.



Sent from my Sprint Samsung Galaxy SIII with M.O.A.R. v9.0, dkp kernel dated 3/20/2014 and TWRP v2.7.0.0.

Yeah I figured it was the same modem just now after doing some more research XD. I also tried the MD4 modem but I didn't get any service (somewhat expected). I'm now back on MK3

So basically you're suggesting that I ODIN to 4.4 and see if that fixes it? Sounds good to me! I wonder if you have a link to a thread with proper files and procedure? If not, I'm sure I can search something up myself haha. (I'm just being lazy at the moment lol)

So basically, I'd Odin 4.4, then odin custom recovery, then root?
The Following User Says Thank You to Thunder_54 For This Useful Post: [ View ]
11th May 2014, 04:07 AM   |  #6  
roirraW "edor" ehT's Avatar
Senior Member
Flag Columbus, OH
Thanks Meter: 1,811
 
3,431 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by Thunder_54

Yeah I figured it was the same modem just now after doing some more research XD. I also tried the MD4 modem but I didn't get any service (somewhat expected). I'm now back on MK3

So basically you're suggesting that I ODIN to 4.4 and see if that fixes it? Sounds good to me! I wonder if you have a link to a thread with proper files and procedure? If not, I'm sure I can search something up myself haha. (I'm just being lazy at the moment lol)

So basically, I'd Odin 4.4, then odin custom recovery, then root?

Exactly like that. Some people get CF-AutoRoot to stick but for some of us including me it would not. There are two or three generations of the SPH-L710 and I'm guessing those of us on the latest generation can't use CF-AutoRoot on 4.4.

What worked for me after your first two steps is to flash SuperSU.zip v1.94 from the custom recovery of your choice. I'd use Philz if I were you.

I, too, am being lazy and don't feel like explaining why at this time, LOL.

Sent from my Sprint Samsung Galaxy SIII with M.O.A.R. v9.0, dkp kernel dated 3/20/2014 and TWRP v2.7.0.0.
11th May 2014, 04:20 AM   |  #7  
OP Junior Member
Thanks Meter: 4
 
29 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by roirraW "edor" ehT

Exactly like that. Some people get CF-AutoRoot to stick but for some of us including me it would not. There are two or three generations of the SPH-L710 and I'm guessing those of us on the latest generation can't use CF-AutoRoot on 4.4.

What worked for me after your first two steps is to flash SuperSU.zip v1.94 from the custom recovery of your choice. I'd use Philz if I were you.

I, too, am being lazy and don't feel like explaining why at this time, LOL.

Sent from my Sprint Samsung Galaxy SIII with M.O.A.R. v9.0, dkp kernel dated 3/20/2014 and TWRP v2.7.0.0.

Cool! Ok, I found this: http://forum.xda-developers.com/show....php?t=2741413

Seems promising. Although while I was waiting I flashed a different 4.4.2 rom with no luck. It is themed and has a different kernel and all though.

So I'll try the one I linked to (which says it's Stock 4.4.x) and let you know what happens
11th May 2014, 06:01 AM   |  #8  
OP Junior Member
Thanks Meter: 4
 
29 posts
Join Date:Joined: Aug 2012
Okay flashed Stock 4.4.2
Okay, so I flashed that ROM from the link in the previous post. It hasn't fixed the wifi problem. I'm starting to think that this is a hardware problem....

Baseband: L710VPUDND8
11th May 2014, 06:05 AM   |  #9  
roirraW "edor" ehT's Avatar
Senior Member
Flag Columbus, OH
Thanks Meter: 1,811
 
3,431 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by Thunder_54

I'm starting to think that this is a hardware problem....

Baseband: L710VPUDND8

I think so too.

Sent from my Sprint Samsung Galaxy SIII with M.O.A.R. v9.0, dkp kernel dated 3/20/2014 and TWRP v2.7.0.0.

Post Reply Subscribe to Thread

Tags
4.3, kernel, wifi
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes