Default WIFI wont connect after manual update to Kitkat 4.4.2

Hello everyone, i'm a new member. I apologize if my english is not good enough.

After been driven insane by one pre-installed app from my Operator (Claro Peru) i decided that it was time to root my device to get rid from that pest. I'm a noob, so i started to investigate about the safest methods to not damage my phone. My Device's model is SGH I337m.

The plan was to update the FW from JB 4.3 that came with my phone to 4.4.2 and then proceed to root. I downloaded the Canadian 4.4.2 FW with build version I337MVLUFNC1 and installed manually with Odin. After the phone rebooted, my S4 was upgraded with 4.4.2 but Samsumg keyboard was going insane, so i went to the apps and solved that cleaning the cache/data. Then i noticed that the Wifi wasn't connected, i tried to turn it on, but then a message with a shield appeared saying that my device security stopped the operation. Beliving it was only a problem with KNOX, i installed autoroot (CF-Auto-Root-jfltecan-jfltevl-sghi337m) with Odin, open SuperSU and stopped it from working, but the Wifi still wouldn't connect.

So the first thing that crossed my mind was to unroot and do a factory reset, didn't work. The FW still was 4.4.2, so ive been searching solutions with this FW because i've read some cases of devices that stopped working completely after trying to do a downgrade. so i don't want to go to that route for now.

After a couple hours of search, some solutions i found on the forum were:

- Install Faux123 Kernel (Found on Youtube, this would be the thread i think http://forum.xda-developers.com/show....php?t=2273437
- Flash a modem for i337m
- Safestrap recovery and bypasslkm.zip
- Downgrade

I haven't tried any of this methods because i dont want to get into a deeper trouble. In the first solution i'm not sure what to do because this is the files the author recommends for canadian models (i337m), but when i enter here http://faux.romhost.me/jflteatt/jb42...jflteatt/jb42/ only jflteatt appears, and that would be i337 model, isn't it? I thought that installing it may cause more troubles, so i didn't do it.

For the flashing modem method, i'm not really sure if installing a modem from another country would get me in trouble, so again i didn't proceed.

I found the Safestrap and recovery method on a downgrade thread for the i337, so again, didn't do it.

So, is there a way to get one of this methods working on i337m to get wifi working again, or is there any other better method to get back wifi.

I would really appreciate any help you can give me guys.