Default [Q] Gapps on TechnoDuos1.5 (Samsung gt-s6102)

Hey people!

I just flashed the Gapps Manager generated zip intended for my Samsung GT-S6102 (Android 2.3.6) over TechnoDUOS1.5 S1525 and everything went down without any trouble.

I had no problem updating Hangouts and installing Youtube, besides Google Market upgrades itself automatically to Play Store.

However, whenever I try to install Google Play Services through play store, it pops up an error 941. This is needed to run both Youtube and Hangouts. Google Maps on the other hand, pops up a different error: "Not compatible with other applications that use the same user-shared ID"

I've already tried almost everything, from blocking Market store from updating, to placing the Google Play Services apk manually to both /data/app and /system/app and changing the permissions manually. All to no avail. I also tried editing /data/system/packages.xml and experimented deleting all <shared-user> tag related to google services framework (which I take is the entry related to google play services). Still nothing.

Is there anything else I can try?

Thank you